Problems with viewport texture resolution on new PC Laptop with NVIDIA GPU

Hi all.

Really need some advice here. Working on an UE4 project that I just transferred from my usual MacBook Pro laptop to a new Windows laptop I bought with a built in RTX 3070.

I was really surprised to see that the UE4 viewport looks kinda ‘low res’ on my new laptop. To be more specific, material textures look blurry / less detailed.

No idea why this is happening as I have the same engine / texture scalability settings on both MacBook Pro and Windows machines, and it’s the exact same project. Are there some other settings I need to configure to make sure I’m seeing the same viewport quality on my new windows laptop? Are there any settings specific to the RTX 3070 GPU perhaps? Right now it’s as almost as though I’m seeing 4k on my MacBook Pro and 720p on my windows laptop.

I’ve attached screenshots - check out how much crisper the bark looks on my MacBook Pro, and the extra detail on the grass.

What could the issue be here?

Any tips on how to optimise the UE4 viewport on my windows laptop would be much appreciated!

Thank you!


Some clown decided to add a feature to reduce game res automatically when you go up in resolution regardless of screen size. Go to editor preferences, search for disable, turn on disable dpi based editor viewport scaling.

1 Like

Legend! Thanks for that.

1 Like