Download

Problems with UVs

Hey

So i am working on a low poly style game for which i need a castle. I’m making the assets in Asset Forge (I’m artistically inept) but no matter how i export it OR import it, it seems to break every time…in a different way… I’ve attached some pictures to explain this a bit more.

So here are 3 different models. All from asset forge. All made on the same day in the same hour(ish). All 3 were exported and imported with the same settings minutes from each other. Yet as you can see, each model has a different error on the UVs. The house has a 100% black side. the other 3 are fine. The middle wall has…that. Its meant to be a solid color wall. The wall on the right is perfectly lit…By that i mean it has no shadows whatsoever. Is there a program that allows me to generate UVs from a finished model and import those into UE4?

I’ve tried multiple export and import settings and messed around with light map resolutions but nothing worked. Anyone pleas help? Google just told me to generate UVs and increase the light map resolution…

PS.: No. All of the above issues are not from the angle of the light. These artifacts show up REGARDLESS of lighting.

Cheers
Dominik

You need to look at your models back in your 3D software and set up your lightmap UV’s properly
First channel is for your materials, second channel is for your lightmaps, it can’t overlap or extend beyond the 0-1 UV space:
https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/index.html?lang=ja

When you import to UE4 disable the option to generate lightmap UV’s, it requires your UV’s to be split properly in the first place so that option is not completely automatic and you can do better if you unwrap the UV’s yourself.

After that, look at each mesh and try to judge what lightmap resolution you need for it, the default is 64 which might not be enough.
Also, try avoiding making flat surfaces out of multiple meshes, it will create lighting issues and each additional object you have in your UE4 map will lower performance, so keeping the number of objects low is important, especially if the objects are simple. Just keep in mind that each object can only have one lightmap so it can end up where an object is too big to get enough detail in a high-resolution lightmap.

Thanks for the reply :slight_smile:

The tool I’m.using (asset forge) doesn’t support making custom UVs or touching them at all. They just get generated at export. Is there an external program that allows me to adjust the UVs after the fact?

Well there’s a ton of software. For freeware, I would recommend using Blender.