Download

Problems with Unreal 4.20 and Datasmith

I’m having Major Issues with Unreal 4.20/4.20.1, Datasmith 4.20.0 and 3dsmax Datasmith plugin 4.20.
when Exiting Unreal for the first time after Importing a Datasmith scene from max the Materials and Lightmass become corrupt (nodes inside a lot of materials become disconnected by themselves, Lightmass becomes a Picasso painting and so on).
I’ve made a 7 Min Video Showcasing the exact problem, Please take the time to view it before responding because it will save us a lot of questions.
THANKS!
VIDEO LINK - https://www.youtube.com/watch?v=EgH03ilju3I&t=22s

Also the scene i used (3ds max 2018 scene to recreate the problem exactly) is Here - https://ufile.io/ss7p7

Hi juliusD ,

Thank you very much for all the precised information and the video . This was very useful.
I’ve logged an bug for you here : Unreal Engine Issues and Bug Tracker (UE-62335)

Cheers

Hi,

I have exactly the same problem : when I save my Datasmith project in 4.20.2, close it and reopen it lightmaps are broken. It’s not Vray material related because I don’t use them. Any clue about this issue?

Can confirm, came problem here, be it with a binary version or compiled from source… Any ETA for 4.21 as you don’t plan a fix before?

UE 4.21 is targeted around late October to early November.

HI Thomas,

We were able reproduce the “broken Lightmaps Issue” on 4.20.2.
Our testing has confirmed that it is no longer an issue in 4.21.

Thank you

We´ve encountered the exact same error with the mixed up Lightmaps and it really drove me crazy, good to hear its “just a bug”. No chance for a bugfix before 4.21?

Great news, thanks!

Hi JuliusD, I had the same problem with the disconnecting textures and it was driving me crazy! I couldn’t find a fix for that, but for the problem you have with the lightmap I could. What I did was delete all the meshes that had lightmap problems, and in 3Ds max I created an Unwrap UVW modifier for channel 2 (leaving my texture mapping intact) and then flattened it. Then I re-imported this meshed via Datasamith, and in the **Static Mesh Build Settings I **used the new UV (in my case 1, as 0 is the texture one) as the source lightmap index and 3 (the UVs automatically created by UE) as the destination lightmap index. I also set 3 as the lightmap coordinate index.

This fixed my black faces problem.
Hope it helps!

Hi CaptainMazza, I see that this issue is fixed on 4.21, have you found any workaround until the new version is released?
thanks!

Is it possible to have a fix for 4.20.3 please? I am in the middle of a project and I don’t feel comfortable moving to a new Engine version as soon as it goes out.

Thanks,
Luigi

I also have similar problems with the lightmap of the object. I edited the faulty objects in 3Ds Max manually (Unwrap Flatern with chanel 2). I tried importing into UE 4 failed objects after editing with 3 versions:

  1. Object at first error (only imported with DataSmith).
  2. Give the object Unwrap Flatern in 3Ds max with chanel 2. then import it using Data Smith.
  3. Same as object 2 but basic import of UE4.
    Result:
    1 and 2: + Source Lightmap Index: 1
    + Destination Lightmap Index and Coordinate index: 2 (Uv map created by tick Generate Lightmaps UVs)
    + UV chanel 0: Uv map is like unwrap chanel 2 from 3DsMax
    3: + Only unique UV chanel 0. Also with Log “has degenerated tangent bases which will result in incorrect shading …”. fix this error by adding a unwrap chanel 1 channel to the object in max, I also don’t understand the reason for this error !?
    after fixed:
  • Source Lightmap Index: 0
  • Destination Lightmap Index and Coordinate index: 1
  • Uv chanel 0 opposite to chanel 1
    Conclude:
    1 and 2: + Source Lightmap Index (SLI): I tried on 2 objects, Source index is always the channel with overlapping UV.
    Why DataSmith changed from channel 0 to channel 1 and its effect …!? If I change SLI to chanel 0, will there be any changes? I can build to see the results and I want to understand why. Looking forward to receiving sharing, thanks

This issue is still happening for me in 4.22.3. I exit unreal and reopen it and some assets’ lightmaps get corrupted like shown in the video. Is there something i can do on my end to solve it other that regenerating the UVs for each asset?

Afaik, the video shows assets (materials) that have their nodes disconnected on re-open, which is not related to lightmaps or uvs. Are we talking about different issues here?

Op mentioned lightmaps corrupting, its in the video as well

you r facing this issue in 4.22.3. weird. this time version is different, in my guess your unreal files must be corrupted. do clean installation again.