Download

Problems with saving the game

Hello everybody,

I am having some strange problems with saving the game and I hope someone can help me.

My game has a main level where if it doesn’t already exist a save is created.

In this level you can choose the character and the choice is saved in the newly created slot or in the existing one if it already existed.

Then I have a game level, when it opens it loads the data from the slot and makes it available to the game. I didn’t check if it exists because to get to this level you have to go from the main level where the save gae was certainly created.

At the end of the game the results are saved in the save game and you return to the main level.

My problem is that the players are unable to save or the data from the save is not read and I believe that the game does not actually create the save game on the slot.

The strange thing is that everything works correctly on my smartphone, perhaps because I already had a previous save due to tests.

Anyone have any suggestions?

Hi man these sentence here is missing some words XD
You can delete the saveslot from unreal using this Delete Game in Slot | Unreal Engine Documentation
you can also delete manually the savegame in your project going in yourproject/ Saved/ SaveGames/ Mysaveslot.sav
You can also change the name of the saveslot , so they cant find a savegame with a new name that does not exist.
But the simplest thing is just deleting them.

So, clear your savegames,
check if they exist,
If you can save something and load it,
it should work everywhere
( just dont load the file multiple times in the same time )

Hi, thanks for the reply.

I tried to delete my “save game” in the slot and the game for me saves and loads correctly but on the cell phone of friends it didn’t work.

I have now changed the slot name and added screen messages to indicate when it succeeds and fails to save or load the slot.

I tried the game and it works fine for me.


If anyone wants to try here is the link to download the beta:

Thank you very much for helping

I double-checked and on some phones it saves and loads correctly while on others it doesn’t.

How is it possible?

I am desperate!!!