Download

Problems with Root Motion

Hey y’all, good to be back.

Or it would be, at any rate, if I weren’t in a bit of a pickle. That’s part and parcel of the whole game design shebang, though, isn’t it.

I just finished watching Crocopede’s tutorials on ledge climbing and wall running and, feeling proud for following along, I whipped up a skeletal mesh in Blender, animated it and brought it into Unreal. A couple of the animations rely on Root Motion to behave properly, and unfortunately, I don’t really understand the system.

Put simply, I’ve got an animation where the character climbs up onto a ledge from a hanging position and no matter what I do, I can’t seem to get the guy from point A to B. I’ve read up on it but haven’t succeeded yet, and there doesn’t seem to be much documentation on the subject.

Near as I can figure I’m supposed to move the root bone from the hanging position to up on the ledge, like this:

77ff7e51721a36eda534f8ff73c7f7dff216388d.png

From the bottom to the top:

508de417afc593367960c7b70ab6a572f8513e6d.png

In UE4, I do the usual, flip Root Motion on, turn it into a montage, but no cigar.

The problem must be on Blender’s end, since the animations supplied by Crocopede work fine. I’ve tried changing the relative location of the root bone, but no matter where I put it makes a difference.

Any help is, of course, appreciated. Have a good day out there, and stay safe.

Looking it over a bit more, I noticed a discrepancy between the standard manniken skeleton and my own. It could be the source of the issue, I’m not sure.

Here’s the bone hierarchy for the manniken:

ue4_manny_root_skeleton.png

Alles ist in Ordnung.

My own skeleton has a different hierarchy, though:

For some reason there’s an extraneous bone, that “Todd_Skeleton” bit at the top. Maybe it’s superseding the root? I’m grasping at straws here. I have no idea why the makeup for the two skeletons is different.

Howdy. I noticed this thread had nearly dropped off the front page, and that sounds like a bad idea, since I’m still in a jam.
I’ve managed a temporary workaround so I can make progress in other areas of the project – I’m forcing the character’s capsule component to move directly – but it looks awful. I’d much prefer this get solved.

In the meantime, I have also made a few adjustments to the character’s skeleton, to make it appear more like the standard mannequin. Looky here:

ue4_todd_root_fixed.png

I’ve done away entirely with the root bone I made and simply renamed the skeleton itself to “Root.” When I imported the mannequin into Blender that was how it looked, so I guess that’s the way things are supposed to be.

It still doesn’t work yet, though. Here’s the skeleton during an animation that manipulates the root:

ue4_todd_root_fixed_2.png

And here’s the same with “Enable Root Motion” turned on:

ue4_todd_root_fixed_3.png

Should be working, shouldn’t it? It’s still a frustration, so I hope someone has insight they can share.

Just a though but check the character details. There should be a check box for “Can Jump” and “Can Fly”. When testing root motion it would be a good idea to turn on in game visibility of the capsule to make sure that it moves and stays with the player model.

Thank you for replying! I’m alarmed to say I can’t find either of those. They’re in the ThirdPersonCharacter blueprint?

EDIT: Found them, right, under Movement Capabilities. Good to know. Changing their value didn’t solve my problem, though.