Problems with Physics Interaction of Character Movement Component

I have a Bus Vehicle with custom physics (skeletal mesh). So I can walk through the bus. In the Player Character I deactivated “Enable Physics Interaction” of the Character Movement Component and I set Collision Preset of the Mesh to “NoCollision”. Mostly all is fine but sometimes I walk in the Bus and the whole Bus is flying through the map. I cannot find any reason for this behaviour. I think with this settings the Character shouldn’t be able to move the Bus.

UE 4.9.2 Launcher Version

Hi user37337,

Thank you for the report. I was able to reproduce this and I’ve created JIRA UE-22527 for the issue. Our developers will be investigating further and we will post back here with questions or comments as we have them.

While testing, the results that I got were less extreme that what you described above. Maybe try increasing the Mass of the bus to see if that decreases the amount that it moves around. If you would like, feel free to upload a test project that showcases the issue and I will take another look. Perhaps we can find a workaround that may lessen the issue.

A workaround that should fix the issue would be to not use a physics asset for the bus at all and constrain it’s movement to a predetermined path (spline, etc).



Is there any progress with this issue?

Hi user,

The devs determined that this was expected behavior because the ‘Enable Physics Interaction’ doesn’t disable all collisions with physics objects. It just controls the code that applies forces when colliding with things.

They suspected that the character capsule is causing the collision issues. If you would like to keep troubleshooting, could you post a test project that has the issue? I previously tested this but I didn’t get the same extreme results as you described.

Hi there. I’m currently facing this problem as well. But it’s slightly different, it seems that no matter what mass a physics object is , the player is able to easily push it like a beach ball. Even turning off Enable PHysics Interaction still let default character do this.

In your comment you mention " It just controls the code that applies forces when colliding with things." Are you referring to when the player touches a physics actor? if that’s the case, then it seems that it’s always pushing regardless of the settings.

Hi Frozenfire,

I’m sorry for the delay.

How are you changing the Mass of the object? It should be done through a Physical Material and not by directly overriding the MassInKg on the asset.

As far as my comment: It’s not pushing as in ‘applying force’ to the other object, however the character can still collide with the physics object. So if you have ‘EnablePhysicsInteraction’ disabled on your characters movement component, it shouldn’t push physics objects around; however, physics object can still bounce off of the character.

I just tested both of these in 4.14.1 and they are working on my end. If you are still seeing the issue, please provide repro steps and/or a small test project.

Just chiming in on the conversation here but I believe there is a chance it has something to do with depenetration velocities.

1 Like