Download

Problems with merging animations onto a single skeleton.

Hello.

Animations and stuff are new to me so I hope someone will be able to help me.
So, my first deal was to re-create an angel from the Heroes of Might and Magic series, which… didn’t start well (since I’m no pro sculpter either lol), so I googled around a little bit and ended up finding someone who has uploaded Cinema 4D files of a couple of animated characters, one of them being one of the versions of the angels I was looking for.
And yes I know that using premade stuff isn’t always the 100% best way to go, but this is just for personal use and for fun, and to try out blueprinting the animations that came with the character.
And since it’s Heroes of Might and Magic there aren’t really plentful of animations to use perhaps around 10-14 animations in total where I would probably just use 5 or 6 at maximum.
So. -I finally found what I was looking for. -The characters are rigged and animated. -Downloaded the .C4D files.
And it took me quite a long time to figure out how to get them on the same skeleton. Because the files that I downloaded came with seperate files with it’s “own skeleton”, even though it’s the exact same character and at first I imported each file on their own into UE4 but as I tried to add the animations in a blueprint (like, moving, attacking etc.), it didn’t allow me because it’s on seperate skeletons. So like I said, I spent perhaps a half day just to learn how to add them into the same skeleton lol.
But even that came with thousands of new problems: the skeletons “don’t match”, even though it’s the exact same character and I assume, using the “exact” same skeleton.
And I believe I >must< use the same skeleton in order to be able to connect them inside a blueprint right? All I want is to turn this angel into a playable character for funsies (nothing too serious), with move, attack animation.
So I spent the entire day yesterday experimenting and trying out different of methods on how to extract and add them in UE4, using both Cinema 4D and 3D Maya.
Let’s say the Idle animation is the “original animation/pose”, if I add it first to UE4 it’s fine, no problems there. If I then add the attacking animation it all goes downhill, resulting 1 of 2 problems. Either I get the error saying the skeletons doesn’t match and I’m able to regenerate them which I’ve tried out, but then the attacking animation doesn’t move (since he sort of moving forwards in the animation while attacking), but yeah, he’s rooted on place, he does swing has blade and his armor is moving, but his waist is frozen in place. Either I get that problem or I get no errors when importing but then the entire character is frozen and then instead moves and swings the way he’s supposed to.
And like I said in the beginning, I know downloading premade stuff isn’t always the best way to go and might be quite unstable (like this), but isn’t there any workaround that I can do?
It is the same character, should be same skeleton even though it’s duplicated over several files etc. etc.
Alone and seperated all the animations are fine, but I can’t connect them in a blueprint onto a character if they’re not on the same skeleton and that’s where it’s all going downhill.

Isn’t there anything I can do to fix this without it being all too complicated? Or should I just accept that they’re more like a “show off” over several files.