Problems with imported tiled terrain from world machine

I have imported a tiled terrain by following the world composition guide.

This is what is looks like in world machine :

For some reason though, in unreal it seems to be very cramped into my scene horizontally (see pic below)

I did do the change required on the Z scale, and the height looks about right, but if you compare the two images, you will see that the imported terrain should be more spread out and less clumped up.

I will add that the help on the forum has been brilliant, and it has gotten me this far, but at this stage I am so close to having it working (I thing, anyways) but have no idea what to do!

I should also mention that it appears to be horizontally flipped somehow.

All help appreciated!

Thanks

Hi

You have to adjust the X and Y scale to fit the terrain size as the size it has in World Machine.

When you import tiled landscape in UE, look at the bottom of the window (just under the scale options) you have a recap that displays the number of tiles and the overall size of terrain. (look at the first screenshot of my post here Importing tiled landscape, how to specify the Z position (not scale) - World Creation - Unreal Engine Forums, for a terrain of 32kmx32km)

As far as I tested it, each tile in UE is around 4km, so adjust the XY scale to obtain the overall size you expect.

For the mirroring issue, it’s a known one, (see here https://answers.unrealengine.com/questions/176590/bug-tiled-world-import-is-broken.html).

At this moment import tiled landscape does not work in 4.7.x, there’s a fix announced for 4.8 (see here https://answers.unrealengine.com/questions/178787/47-worldcomposition-import-tiled-landscape.html)

Hope this helps a bit

Cheers

put 20 /25 /50 in the Z scale value, what i use