Problems with FBX animation: curve information discarded, keyframes removed, animation too fast

I’m having so many problems with this animation that I’m sure I must be missing something.

[Attached here][1] is a .3ds and matching .fbx file for a lever I’m trying to animate with a single bone. I exported the .fbx file in ASCII format just to double-check that things were getting exported as I expected. The animation is in four parts: a default pose, an untransformed pose, a down animation, and an up animation.

The first issue is that after I import the animation, Unreal reports that the animation has 6 frames, but the .3ds and .fbx files both have 9 frames.

Second, the animation seems to have discarded the curve information. Here’s a comparison of the curve I expected to see (green) and the curve that appears to be happening (pink):

The two rest poses should clearly remain stationary, but Unreal gives me a smooth animation. The little notches at the end of the up/down animations also seem to be missing. At first I thought Unreal was ignoring the stepped curve types, but the notch at the beginning of the down animation is just an ordinary spline; it’s a little bit more subtle, but it appears to be missing as well.

Finally, the animation is running too fast! Unreal recognizes that the animation should be 5s long, but it runs through the whole thing in about 4.6 seconds, and then remains stationary for the last 0.4s.

These problems all seem to be solved if I export with the “Bake Animations” and “Resample All” options, but then I get 151 keyframes, which isn’t exactly optimal.

Is this a PEBCAK issue, or am I hitting multiple bugs?

Using Unreal 4.3.1 and 3ds Max 2015.

You can freely use the “Bake Animations” and “Resample All” options. The UE4 FBX importer samples animations at an uniform rate anyway, because later on, during the creation of the runtime data for the anim, the frames are reduced as much as possible and then compressed.

Did you find a solution to your problem yet? It seems pretty related to my question.

I ended up just “Bake Animations” and “Resample All”. I’m not sure if Maya’s FBX exporter is any different than Max’s, but those options basically just export a keyframe on every single frame, instead of relying on the curves.

Maya has pretty much the same options. Baking per frame solves the smooth interpolation that is happening between key-frames but not the one between frames. This is what I am trying to fight since the engine will try to display sub-frames.