Download

Problems with cooking

Sometimes if i cook no file except my preview Picture and my mod.info is included in the workshop/content/mod directory.
Am I doing anything wrong?
I followed several guides.
The cooking just worked properly 1 time where it successfully build the mod which worked correctly.
Please help.

What does your mod involve? It sounds like either the primalgamedata isn’t being referenced correctly, or in general things aren’t being referenced correctly. In order for me to be able to be of further help I need more info than provided. Info on the mods functionality, what method you used to clone existing bp’s, etc etc. Alot of things could be at play here, so we need to be thorough about it :slight_smile:

  • Sinari

After upgraded to v190, the some problem occur in mine. Sometimes you fixed it by renaming the Project, but it might fail next time.

Hmmm, strange. Someone else reported similar problems as well, in addition to myself having somewhat related problems to this. Going to bring this to the Devs attention asap.

All I can suggest for now is rename your mod folder as a temporary fix, or explore to find another work around until we can get this one fixed :confused:

How does the cooking log look? Any errors or does it go by much quicker than you would think?

I’m having a helluva time with this as well. I’m new to UE in general so i’m not frustrated yet, just trying to fix everything that could be wrong one step at a time. I uploaded and downloaded the ‘UberMini’ map to the steam workshop successfully once. Since then, I have not been able to download a working version from the workshop. The cook process and upload seems to work just fine, but when I start up the updated map I get kicked out to the loading menu. I’ve put PrimalGameData_BP into world settings and have created a new map name and new Mod folder for it previous to cooking and uploading. What should i try next?

This is another unrelated issue you are experiencing from the sound of things, just a heads up. Generally speaking you should start another thread as to not clutter up another one with unrelated questions.

But here’s the answer to your problem: If you are getting kicked to the loading menu, then it sounds like you don’t have it set to force load your map under the world settings potentially. Set it to force load your custom .umap file and I believe that should resolve it.

If not please post a new thread with additional details so I can help troubleshoot it for you. I’m taking a swing in the dark at the culprit right now due to lack of info and background on the mod. The more info you provide, the better picture I get of the situation, and the more accurate my troubleshooting is as a result :slight_smile:

  • Sinari

Well, i found out that the cooking always worked fine. The uploading worked fine as well. The only thing that did not work well is the download of the mod to your workshop folder. I don’t know how or why it is bugged. Sometimes you get all the files, sometimes just the thumbnail with the GenericMod umap …

Having the same issue. Anyone find a fix for this?

This is still a issue, and a large one at that. ive made about 7 or 8 different mods. only one of them correctly downloaded the assets, but it would crash my game anyway.