Problems using sprites and 3D textures in iOS package

When building a game for shipping in iOS the sprite goes black, and the 3d textures stay in low quality. This only happens in iOS, Android is all fine.


Hi Multiverso D,

iOS is going to use Metal for rendering, whereas Android is not. Hence make sure your Project Settings are set up accordingly:

Project Settings>iOS>Build: Make sure you have selected armv7, arm64, and armv7s

When I check the armv7s I keep recieving the error exit code 15.

Please post entire output log and or error log as a text file.

The log: Google Drive: Sign-in

Tell me if the document dont open.

Hi Multiverse,

You have a number of warnings that are causing your assets to properly build that follow this general formula:

“File was built for archive which is not the architecture being linked (arm64)”

"One solution I’ve found for this error is: “When you’re building a library you must compile it both for the simulator and the device and then merge the two outputs (.a files) into 1 library and then link it to your iOS project.”

Another solution is:

"In your framework project in xcode click on your project (blue icon). Then make sure to SELECT YOUR FRAMEWORK target from the list of targets. Next go to “Build Settings” Tab and set the Property “Build Active Architecture Only” = NO. Finally under the “Valid Architectures” property I added “armv7, armv7s, i386”

If neither of these resolve the issue, search for the term in bold to find a solution more applicable to your specific case.