Download

Problems uploading to steam workshop

Hi, I have a problem uploading my mod to steam workshop. Everytime I tried it calls an error after I press the upload button and enter my steam account. It says “ERROR! Failed to parse build config file “…Epic Games/ARKDevKit/ModTools/ModConfig/MyMod.vdf””.

If anyone can help me with that please tell me what to do, I tried deleting the “.vdf” file and re-cooking my mod and uploading again, I even erase the mod on the workshop before doing this, with no success.

Thanks.

Hi patqc24,

have you got any special characters in the title / description ?

[WIP]

Would that cause an error above?

I would try it with no special characters at all and do not make your patch notes in the updates wait and edit your steam page for that. If you get a parse error I have been dealing with it for months you will have to use steamcmd.

you are in an unfortunate place some how your .vdf has been corupted, but here is how I fixed this … warning it sucks.
open your mod page in the steam workshop and right click copy page url and paste to a text editor to get the PID the numbers at the end…if you don’t know it already.
In the dev kit upload dialog ‘reset publisher’
upload to steam as a hidden file
log out/ exit steam completely
open file - #:\Epic Games\ARKDevKit\ModTools\ModConfigs’modname’.vdf in a text editor and change the PID back to your original one and save the file.
go to your - #:\Epic Games\ARKDevKit\ModTools\SteamCMD\ directory and launch steamcmd.exe
type - login ‘password’ ‘login’
type - workshop_build_item #:\Epic Games\ARKDevKit\ModTools\ModConfigs’modname’.vdf
type - quit
close the window
open steam and delete the extra hidden mod

where ’ ’ is your own information and #:\Epic Games\ARKDevKit\ is your complete dev kit path including drive
you will have to follow this process with every update from now own unfortunately.

I hope you don’t have to do this but I have been doing it for moths because mine won’t update.

Developer
http://steamcommunity.com/sharedfiles/filedetails/?id=507355109&tscn=1442652946

Not sure if your talking to me or not, but iv got 1 failure that keeps showing up and I have no idea how to fix it. Everything uploads and is updated to the workshop otherwise.

Yes I was talking to you, My reply was in regard to the uploader throwing a parsing error. It is a known problem and steamcmd is the only solution I have seen. If you are not getting a parsing error on upload disregard. Sorry it has just been a very common problem.
Thanks,
Tom

What do you recommend I do to find out what is causing the one cooking failure?

From your description your mod is cooking fine the error is on the upload and the screwed up way steam workshop operates on uploading. It your .vdf that is failing to be parsed. If you follow my instructions a new .vdf will be created that you can edit and then use steamcmd to upload to the same location you have been using… For some reason it is not letting you upload ‘normally’ to the same location hence ‘reset publisher’ but then your update will not have the same PID that previous subscribers can find. I had it happen to me 2 months or so ago and after much research I found steamcmd.exe posted on the steam forums somewhere. I poked around and came up with the solution I posted. If you find an easier way please let me know I dread updates atm. Long story short it is the only method I have found or heard of to force a workshop load.

Edit - that was a bit confusing I realize after rereading it. The point of the whole procedure posted is to force a workshop load to the same PID you where using. If you don’t care just press ‘reset publisher’ it should create a new .vdf and off you go.

Edit again - the error posted has nothing to do with the cook process only the upload.

Silly me, should of read my message log, had a missing animation in my anim blueprint. Usually ignore it due to the constant missing:

Info Failed to load /Game/PrimalEarth/CoreBlueprints/PlayerPawnTest_Male.PlayerPawnTest_Male_C Referenced by PrimalInventoryBP_AnvilBench_C Property /Script/ShooterGame.PrimalInventoryComponent:DefaultInventoryItems
Error /Game/PrimalEarth/CoreBlueprints/Items/Structures/BuildingBases/PrimalItemStructure_BaseCeiling : Can’t find file for asset. /Game/PrimalEarth/Structures/Wood_Structure/Ceiling/Ceiling_Wood_SM
Info Failed to load /Game/PrimalEarth/CoreBlueprints/PlayerPawnTest_Male.PlayerPawnTest_Male_C Referenced by PrimalItemStructure_BaseCeiling_C Property /Script/ShooterGame.PrimalItem:StructureToBuild
Error /Game/PrimalEarth/CoreBlueprints/Items/Structures/Metal/PrimalItemStructure_MetalCeiling : Can’t find file for asset. /Game/PrimalEarth/Structures/Wood_Structure/Ceiling/Ceiling_Wood_SM
Error /Game/PrimalEarth/CoreBlueprints/Items/Structures/BuildingBases/PrimalItemStructure_BaseWall : Can’t find file for asset. /Game/PrimalEarth/Structures/Wood_Structure/Wall/Wall_Wood_Small_SM_New
Info Failed to load /Game/PrimalEarth/CoreBlueprints/PlayerPawnTest_Male.PlayerPawnTest_Male_C Referenced by PrimalItemStructure_BaseWall_C Property /Script/ShooterGame.PrimalItem:StructureToBuild
Error /Game/PrimalEarth/CoreBlueprints/Items/Structures/BuildingBases/PrimalItemStructure_BaseWallWithDoor : Can’t find file for asset. /Game/PrimalEarth/Structures/Wood_Structure/Wall/Wall_Wood_Small_SM_New

great to here glad you didn’t have the dreaded fail to parse .vdf…that one really sucks. They need to fix it badly would be easy enough to let us enter our own PID in the dialog I would think. Gratz on your success best of luck!

I just got this parse issue, turns out I hit the word limit for the workshop page.

Yeah, my ACM mod does this too. If you’ve ever seen the page you’d know why lol.

Seems to only be a SteamCMD issue. Haven’t come across a limit on the workshop itself, yet. So I usually type out and changes and additions to the description, then replace it with random **** when uploading and paste in the description after it’s uploaded on the workshop.

-WM

1068 words or as many lines on my mod page and you will get the error “There was a problem trying to save the title and description.”

Yeah, I get it every now and then, generally I have to go back through and condense the description lol. Apparently it’s at 1006 words, at the moment. My next update will push me over that so I’ll have to strip info somewhere.

-WM

ok, so im making a map for a game called the isle, but everytime i try to upload to the workshop i get ERROR! Failed to load build config file, not a parse, but still. im not sure how to fix this as ive uninstalled and reinstalled the uploader already, checker all the grammar, punctuation, spelling, and tried repackaging my mod, nothing worked, any ideas?