Problems updating project to 4.4

Hey DaveHall17-

Could you post your DXDiag for both machines? If the project is working for your colleague and you are still experiencing issues you may need to uninstall the engine and then reinstall it.

There is another thing to check before attempting a reinstall. Can you check the QUBEHUD.cpp file and make sure that the include for ‘SQUBEPauseMenu.h’ is referencing the correct location?

Hi Doug,

Here is the DXDiag for my Laptop running Windows 8 . I can upload the DXDiag from my work PC tomorrow .

Thanks

link text

It says:

#include “SQUBEPauseMenu.h”

It does not reference any location.

Is there a pound sign before the include?

You may need to try uninstalling the engine and then reinstall it.

No , from the top it says.

/**

  • Copyright 2013 Toxic Games, Ltd. All Rights Reserved.
    */

#include “QUBE.h”
#include “Slate.h”
#include “SQUBEPauseMenu.h”
#include “DrawDebugHelpers.h”
#include “QUBELoadingScreen.h”

DEFINE_LOG_CATEGORY_STATIC(LogHUD2, All, All)

It does , but it changes when I copy it into here . The # symbol gets removed and the size of the text increases.

Hey DaveHall17-

It seems as though there may be a problem with your install of the engine. Have you had the chance to try uninstalling and reinstalling yet?

I have tried both by verifying the install and by doing a clean install , but I get the same error .

By the way when you say a pound sign do you mean £ or # ?

I was referring to the second (#). It seems your include statements are correct.

Are you able to take your 4.2.1 project and convert it to 4.3 rather than converting straight to 4.4? If so can you then convert the 4.3 project to 4.4 from there?

I tried updating to 4.3 , but I still get the same error message .

Just to double check a previous question can you check that the file SQUBEPauseMenu.h is in the same folder as QUBEHUD.cpp?

After that right click on the .uproject file in your project folder and select “Switch Engine Version” followed by “Generate project files”. Then run the .sln (visual studios) file and right click the project name and select Build. Then try running the .uproject file again.

I am able to switch engine version and generate project files successfully . Both files are in different locations , to begin with :

QUBEHUD.cpp is in Source\QUBE\Private\Engine

and

SQUBEPauseMenu.cpp is in Source\QUBE\Private\UI

If I recompile I get the following error messages.

Error 1 error C1083: Cannot open include file: ‘SQUBEPauseMenu.h’: No such file or directory C:\Users\Dave\Documents\Unreal Projects\QUBE_Rocket_Development\Source\QUBE\Private\Engine\QUBEHUD.cpp 7 1 QUBE
Error 2 error : Failed to produce item: C:\Users\Dave\Documents\Unreal Projects\QUBE_Rocket_Development\Binaries\Win64\UE4Editor-QUBE.dll C:\Users\Dave\Documents\Unreal Projects\QUBE_Rocket_Development\Intermediate\ProjectFiles\ERROR QUBE
Error 3 error MSB3073: The command ““C:\Program Files\Unreal Engine4\4.4\Engine\Build\BatchFiles\Rebuild.bat” QUBEEditor Win64 Development “C:\Users\Dave\Documents\Unreal Projects\QUBE_Rocket_Development\QUBE.uproject” -rocket” exited with code 2. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 43 5 QUBE

I get the same error if I move SQUBEPauseMenu.cpp to Source\QUBE\Private\Engine

The same happens If I move QUBEHUD.cpp to Source\QUBE\Private\UI

I have attached an image of where each file is by default . I have tried moving files between each folders , but have not yet been able to successfully build the project .

Could you create a new project and transfer a few files over at a time? This will help narrow down which files are working properly and which files are causing this compile error

I created a blank project called “TestProject” I was able to copy over all files apart from Config\Defualt Engine and the editor would load. There was no custom game mode , which is need to play the game properly .

When I copied over Default Engine it said there was a problem with game URL.
I copied over QUBE.uproject . I then generated project files , but was unable to recompile the source code.

I tired again with a blank project called QUBE . I was able to copy over everything apart from Config\DefaultEngine and the editor would load , but there would be no custom game mode .

When I copied over Config\DefaultEngine It did not ask me to generate project files or compile the source code , but the editor would crash if I tried to load it . The same thing happened after generating the project files.

I was able to successfully compile code in VS which I was not able to before . It does not say the the module needs to be recompiled or is out of date . When I load the editor it crashes .

This is the crash log .

!Id:e99b4f2873ddb4e8aaf6e6f43f25976f

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: GameViewportClientClass != NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.4\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp] [Line: 1322]
Engine config value GameViewportClientClassName is not a valid class n

KERNELBASE + 37901 bytes
UE4Editor_Core + 3095292 bytes
UE4Editor_Core + 1661738 bytes
UE4Editor_Core + 1541824 bytes
UE4Editor_Engine + 9016655 bytes
UE4Editor_UnrealEd + 1712495 bytes
UE4Editor_Engine + 9004409 bytes
UE4Editor_UnrealEd + 1708367 bytes
UE4Editor_UnrealEd + 1700548 bytes
UE4Editor_UnrealEd + 5772394 bytes
UE4Editor!FEngineLoop::Init() + 526 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.4\engine\source\runtime\launch\private\launchengineloop.cpp:1871]
UE4Editor_UnrealEd + 5627284 bytes
UE4Editor!GuardedMain() + 285 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.4\engine\source\runtime\launch\private\launch.cpp:125]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.4\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.4\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hey DaveHall17-

Thank you for all of the information provided, I have entered a report into our database (TTP #348936) for further investigation.

You should set GameViewportClientClassName in your projects DefaultEngine.ini to GameViewportClient and see if that fixes it.

In Config\Default Engine it is currently set to .

[/Script/Engine.Engine]
GameViewportClientClassName=/Script/Engine.GameViewportClient
GameViewportClientClassName=/Script/QUBE.QUBEGameViewportClient

The editor will load , but custom game class is missing so none of the blueprints work if it is set to.

[/Script/Engine.Engine]
GameViewportClientClassName=/Script/Engine.GameViewportClient

The editor will crash when loading if it is set to .

[/Script/Engine.Engine]
GameViewportClientClassName=/Script/QUBE.QUBEGameViewportClient

or

[/Script/Engine.Engine]
GameViewportClientClassName=/GameViewportClient

This is the crash log .

!Id:e99b4f2873ddb4e8aaf6e6f43f25976f

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: GameViewportClientClass != NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.4\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp] [Line: 1322]
Engine config value GameViewportClientClassName is not a valid class n