Problems updating project to 4.4

Hey DaveHall17-

Does this happen if you create a new project and then try to convert it?

Using any of the templates provided would work.

Hi Doug ,

I updated the engine to 4.4.3 . I then created a project in 4.2.1 using the FPS code template . I then converted it to run on 4.4.3 and it works fine .

I then tried it with our own project to see if updating to 4.4.3 makes a difference , but I got the same error message as before .

It’s possible that there could be a level that has been corrupted in some way. In the folder where your project is located, go into the Content folder and pull out the entire Maps folder (you can move it to the desktop during this process so you don’t lose them). Then try updating the project again.

Hi Doug ,

I tired deleting the Maps folder before converting the project and received the same error . I then tried deleting the content folder as well and still got the same error .

Hey Dave-

When you built the engine from source did you configure the directory as an Unreal Engine installation? To do this you can go into the folder where the source code is and then go into Engine->Binaries->Win64 and scroll to the bottom of the folder to “UnrealVersionSelector.” Here is a link that walks through the entire process of getting source code from Github with the necessary steps near the bottom of the page.

Once it has been done the other thing to check would be to right click the .uproject file for the project and select the “Switch Unreal Engine version” and choose the engine version you’d like to work in.

Cheers

Doug Wilson

Hi Doug ,

I think there has been a bit of confusion . I have only ever installed UE4 via the Unreal Engine Launcher . It was my mistake when I said that I tried via source in a previous post .

I have looked for the “UnrealVersionSelector” , but can not find it . Does it show if you install via the Unreal Engine Launcher ? And should I be looking in the 4.2. or 4.4 folder?

Thanks

Hey Dave-

In that case you don’t need to worry about the UnrealVersionSelector, that is a file that exists if you build the engine from source. You say that your colleague was able to convert the project without this problem. The simplest solution may be to completely delete the project from your computer and get a copy of the 4.4 version on their computer. That being said it may be worth getting a copy of your colleague’s 4.2 version of the project and then convert that on your machine just as a test of the project version you have.

Cheers

Doug Wilson

All of the project files are saved on the SVN and I have tried creating a new project using files from the SVN with no success . This is the method we have used before when updating the engine and it usually works .

Can you think of any other reasons that it may not be working?

Is it possible to get a zip file of the project from your colleague? Either on a flash drive or by email / google drive or some other source?

Hi DaveHall17,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you

Doug Wilson

I am still unable to update to 4.4 . I have tried the steps mentioned on both my work PC and my laptop and I always get the same error message .

Hey DaveHall17-

Could you post your DXDiag for both machines? If the project is working for your colleague and you are still experiencing issues you may need to uninstall the engine and then reinstall it.

There is another thing to check before attempting a reinstall. Can you check the QUBEHUD.cpp file and make sure that the include for ‘SQUBEPauseMenu.h’ is referencing the correct location?

Hi Doug,

Here is the DXDiag for my Laptop running Windows 8 . I can upload the DXDiag from my work PC tomorrow .

Thanks

link text

It says:

#include “SQUBEPauseMenu.h”

It does not reference any location.

Is there a pound sign before the include?

You may need to try uninstalling the engine and then reinstall it.

No , from the top it says.

/**

  • Copyright 2013 Toxic Games, Ltd. All Rights Reserved.
    */

#include “QUBE.h”
#include “Slate.h”
#include “SQUBEPauseMenu.h”
#include “DrawDebugHelpers.h”
#include “QUBELoadingScreen.h”

DEFINE_LOG_CATEGORY_STATIC(LogHUD2, All, All)

It does , but it changes when I copy it into here . The # symbol gets removed and the size of the text increases.