Problems exporting/importing FBX files

Hello everyone

My name is Pabl and took about 2 weeks testing the UDK game engine, and have had a number of problems since I want to use the Unreal engine or 4 to make mini locomotive simulators.
When you import the 3D in assets is important that the hierarchy remains as to the movements of the components that interests me.
The problem is that when recognizes and imports the parts separately, I can not put the assembly in a scene and have to put piece by piece, we are talking about 3D with 4700 pieces. I wonder if there is any way for any of the two programs keep the hierarchy, and the scene I load the assembly.
Did you mean: además me gustaría saber si existe la manera de exportar una animación hecha en el programa en el formato .avi o similar
I also wonder if there is a way to export an animation made in the program in the .avi format or similar.

Thank you

If the object is animated, then you must have a common root object that everything else is attached to, it can be a mesh, or it can be something like a dummy object, but everything must be attached to it or they will be separated. When importing, make sure it’s set to import as a skeletal mesh, and that you check the box Import Rigid Animations

If it’s not animated, you can import as a static mesh, make sure to check the box Combine Meshes

Thanks for the post, but i don’t know how to have a root object. Which option allows me to attached everithing to a single mesh or dummy. After that, my question is if I will be allowed inside the scene to animate each mesh or not, is important for me to move the 4700 meshes separately.

If you’re using 3ds Max, the dummy object is just a blank object, you can use the Link tool to attach all of your other objects to it, and then that dummy becomes the root to the other objects, you can then animate the other objects like you would normally and export to UE4, it will import as a single skeletal mesh. In the skeletal mesh it will have a heirarchy, though what you can do with that I’m not sure.