Problems creating and Attaching Rotating Objects

Hello there,

I am currently working on a Project where I want to Attach a Rotating Objects (for example wheel) to a parent Object and be able to have physical interactions.

The Problem is that when I have my Wheel alone with nothing attached, It works perfectly and the wheel can move around. But as soon as I want to Attach it on another Object and make the Object the Wheels Parent the Wheel still rotates and everything, but doesn’t move at all.
I even tried creating a Physical Constraint inside the Parent wich Connects the Rotating Object with the Parent but still, the rotation doesn’t seem to affect the parent at all.

As seen in this video of my testlevel you can see the Wheel Blueprint on its own is working on moving along. But as soon as Attached to another
Objekt like a Cube which is Simulating Physics, it doesn’t work anymore regardless of what I tried and I tried a lot of different stuff to get it to work.

The Vehicle and Advanced Vehicle examples did not help at all since I am using a more modular system. For once they are very complicated and are all working with one single skeletal mesh instead of multiple parts which I would want to use. I tried creating a single Skeletal Mesh Wheel and Attach it but that always results in an instant crash of the editor as soon as the parent is simulating physics.

Maybe I am going about this the wrong way and I need to change how I do it, but for now I am completly clueless how to resolve my issue. Every attempt I have tried failed and either didn’t work or crashed the editor.

So my question is what do I have to do to get a Blueprint Wheel to work, when its attached to another physical Object?

Bumping :slight_smile:

Interesting question. We did physics based stuff the last couple of months. Our area of expertise :slight_smile:
I just did a quick one. The front wheels if you want. Works really nice. Extending it to a car is just adding more constraints and bodies.
You can jump off the ramp!

Numpad 1 is forward. Numpad 2 is reverse. The Debug Lines you were the force attacks and the direction.

Thanks a lot! That helped me figure out my problems. I wasn’t aware that you could spawn Constraints Actors, and only used Constraint Component which doesn’t seem to work that way :slight_smile: