Download

Problema com Unreal. Travando!

Ola.

Estou com problemas com meu Unreal. Infelizmente ele tem travado assim que eu abro o pograma.
Ja fiz inumeros procedimentos. Reinstalei, alterei o registro, mudei as configurações da Placa de Video,
instalei novos drivers, atualizei o Windows, mas infelizmente ele continua travando.

Alguem poderia me ajudar?

Agradeço.

1 Like

Não entendi a parte do estar travando. A segunda imagem que você mandou mostra o editor aberto. Você não consegue clicar em nada? O editor parou de responder?

Essa imagem eu capturei com o editor travado. Ele trava apos alguns segundos de uso. E partir dai não consigo mais utilizar. Não consigo nem finalizar a tarefa UnrealEngine. Tenho que resetar para poder novamente tentar utilizar.

Lembrando que estou utilizando ele em meu nootebook. Mas pelo que vi as configurações que possuo me permitem utilizar.
Obrigado.

Coloca aqui as configurações do seu notebook pra ter uma ideia.

Eu fiz uns prints da configuração do sistema que utilizo no post. Mas seguem algumas informações.
Valeu.

Nome do sistema operacional: Microsoft Windows 10 Pro
Versão do sistema operacional: 10.0.19041 N/A compilação 19041
Fabricante do sistema operacional: Microsoft Corporation
Tipo de compilação do sistema operacional: Multiprocessor Free

Fabricante do sistema: Avell High Performance
Modelo do sistema: Avell G1555 MUV / A62 MUV
Tipo de sistema: x64-based PC
Processador(es): 1 processador(es) instalado(s).
[01]: Intel64 Family 6 Model 158 Stepping 10 GenuineIntel ~2600 Mhz
Versão do BIOS: American Megatrends Inc. N.1.03, 19/08/2019

Memória física total: 16.242 MB
Memória física disponível: 6.093 MB
Memória Virtual: Tamanho Máximo: 20.338 MB
Memória Virtual: Disponível: 7.186 MB
Memória Virtual: Em Uso: 13.152 MB

Placa de video1: Inten(R) UHX Graphics 630
Total de Memoria: 8249 MB

Placa de video 2: NVIDIA GeForce GTX 1650
Total de Memoria: 12083 MB
Driver versao: 27.21.14

Versao do Unreal que utilizo e a 4.26.0

Interessante que você tem duas placas de vídeo. Quando você abrir a Unreal novamente, tenta ver no gerenciador de tarefas qual GPU está sendo utilizada. Se for a sua UHX Graphics tem que dar um jeito de usar a GeForce.

Você pode também verificar os logs da Unreal Engine. Os logs ficam na pasta %APPDATA%…\Local\UnrealEngine\4.25\Saved\Logs.

Tenta ver se tem alguma informação útil nos logs.

Opa…

Verifiquei que o Unreal esta inicializando a Engine com a GPU placa de Video da intel pelo Log na pasta que me informou.

Busquei na net e encontrei esse link Explicitly choosing which GPU to use - UE4 AnswerHub

Inseri no arquivo Engine.ini a linha r.GraphicAdapter = 2

Mas continua inicializando com a GPU integrada.
Como posso definir que ele inicialize pela placa Nvidia?

Segue algumas informações do log

LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogOnline: OSS: TryLoadSubsystemAndSetDefault: Loaded subsystem for module [NULL]
LogInit: Build: ++UE4+Release-4.26-CL-14830424
LogInit: Engine Version: 4.26.0-14830424+++UE4+Release-4.26
LogInit: Compatible Engine Version: 4.26.0-14830424+++UE4+Release-4.26
LogInit: Net CL: 14830424
LogInit: OS: Windows 10 (Release 2004) (), CPU: Intel(R) Core™ i7-9750H CPU @ 2.60GHz, GPU: Intel(R) UHD Graphics 630
LogInit: Compiled (64-bit): Dec 1 2020 15:13:26
LogInit: Compiled with Visual C++: 19.24.28315.00
LogInit: Build Configuration: Development
LogInit: Branch Name: ++UE4+Release-4.26
LogInit: Command Line:
LogInit: Base Directory: C:/Program Files/Epic Games/UE_4.26/Engine/Binaries/Win64/
LogInit: Allocator: TBB

Obrigado mano.

Infelizmente eu não tenho como testar no meu pc já que eu só tenho a placa de vídeo dedicada. Se eu achar alguma coisa eu posto aqui mais tarde.

Ok, agradeço mano.

Ainda estou tentando porem ainda está travando.
Tentei modificar para inicializar a GPU da NVidia, mas sem sucesso.

Continuo tentando.
Valeu.

No Windows, clica com o botão direito na icone do Unreal Engine, no sub-menu provavelmente tem uma opção Escolha a Placa Gráfica, mude para Nvidia, sucesso.
Seria recomendável você usar a UE4.23.1 que é uma versão mais estável e mais “leve”.

Verifiquei aqui e não encontrei esse sub-menu em nenhuma aba do executável Unreal. Não encontrei uma opção que me permita escolher qual GPU que ira inicializar.

Se você puder me ajudar detalhando.

De qualquer maneira reinstalei a versao 23.1 como você disse e estou testando, porem ainda continua travar.

No gerenciador de tarefas, verifiquei e a GPU que o unreal inicializa e a 0.

Espero conseguir.

Obrigado mano.

Eu não sabia que o Windows removeu essa seleção de GPU do sub-menu, faz sentido você não encontrar com Windows10 atualizado.

Duas coisas que você precisa fazer:
1o - Atualize o driver da Nvidia. Vai no site da Nvidia, Downloads, escolhe o modelo da sua placa de vídeo, faz o download do driver, instala, reinicia o Windows.
2o - Configure o Settings do Windows para iniciar a UE4 usando a GPU Nvidia. Os links abaixo tem instruções de como fazer isso, se não entender inglês joga os links no Google Translator e segue as instruções.
https://nvidia.custhelp.com/app/answers/detail/a_id/5035

Boa sorte.

Infelizmente continua travando.

Ele ta inicializando na GPU 0 que e a Placa NVidia, porem continua travando.

Eu ja havia feito isso. Inclusive testado a opção economia de energia que utiliza a GPU integrada e a opção de alta performance com a GPU NVidia mas em ambos os casos tem travado.

Os drivers também ja atualizei da GPU NVidia.

Interessante que na versao 4.23.1 o editor mal abre e trava.

Na versao anterior 4.26.0 ele permitia fazer alguns ajustes em minha cena.

Engraçado que em outro computador ele funciona normal, um iMac com configuração inferior ao notebook.

De qualquer maneira obrigado mano.

Vou tentar executar em modo Debug para saber onde exatamente esta travando, preciso instalar algumas coisas.

Você já fez isso alguma vez??

Valeu!

Vou continuar tentando. Foda!

Ainda tentaria seguir essas dicas, esse número dos seus prints sobre o driver da Nvidia não está certo.
v27.21.14? Os drivers atuais da Nvidia tem número de versão igual a 456.71 ou similar.

Eu também achei que não, mas se você olhar no “Informações de Sistema” esse número é o que vai estar lá. Eu tenho o 457.51 instalado. Eu acho que esse é algum outro número, pode ser a versão do instalador em vez da versão do driver.

O meu tem esse mesmo número e no painel de controle da NVIDIA tem o driver esperado.

Opa mcleary.

Entao eu ja havia atualizado, só não coloquei aqui o print.
De qualquer maneira continuo tentando mano.

Infelizmente ate o momento sem sucesso.

Quero rodar fazendo Debug para saber exatamente onde ele trava.
Estou buscando informações no youtube.

Obrigado mano!

7fb4c44b6e5d1841fd6fe44bec28e00f02585d0c.jpeg

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_209017_1607482535364_655”,“title”:“capt2.JPG”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_209016_1607482115850_473”,“title”:“capt1.JPG”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

Painel de Controle ==> Gerenciador de Dispositivos ==> Adaptadores de Video ==> UHX Graphics 630 (desabilitar dispositivo).

Oi Bruno,

Então eu desabilitei a GPU Integrada e aparentemente ele parou de travar.

Existe uma maneira de acelerar o uso dele na tela do Notebook. Ele esta rodando porem de forma lenta.

Como faço para acelerar o desempenho.?

Como utilizo um monitor estendido nesse monitor ele roda bem melhor.

Porem ao trabalhar em casa utilizo apenas a tela do Notebook.

Obrigado mano.

Qual a resolução da sua tela do notebook?

Um outro detalhe que percebi que ao desabilitar a GPU integrada quando utilizo apenas a tela do notebook o Windows não reconhece como Placa principal a NVidia, nas configurações graficas.
Não consigo tambem acessar as configurações de desempenho da NVidia, utilizando a tela do Notebook.
Acredito que elas trabalham de forma integrada.
Preciso saber se tem como definir a NVidia como default depois de desabilitar a GPU integrada.
As configurações da NVidia sumiram ao desabilitar.

Obrigado.