Download

Problem...

Hello guys, i am trying to solve this problem for 3 days, changed lightmap UV in max milion times still doesnt have a clue what is happening and how to solve this problem. Tried to put resolution of lightmap to 1024 no good result, some of assets (tables) low down from 64 to 32 helped…what to do ? Also i is it better to post questions here or on answers.unrealengine.com image_148545.jpg

Could you post a screenshot in lightmaps density mode (alt+0)? I think your walls are too big for even 1024 resolution.

these are not walls these are bottom of the sofa :smiley: just isolated to see problem ? they are orange on light density. I still doesnt know what is problem :smiley: light quality is production (calculated in 10 seconds gtx960 4G when i have overlap maps it take ages to calculate), every asset is open in max and created custom UV for lightmap in 01 space so there are no overlaps and plenty of room between them. resolution is 64 to all

Opsy, I thought those were walls. :smiley:

Ok, you need a orange/red color on the lightmaps which will mean that you have enough pixel density for nice and detailed shadows.

Could you post a screenshot of your lightmass settings?

I am scratching my head? Wasn’t red color too dense and blue under dense (using too much resources for calculating… memory etc) and green sweet spot?? also I just realise crosshatch pattern of lightmap on tables so i changed direction of maps in UV space it looks it has less problems but still have?

Red color is perfect pixel density, the quads you see represent pixels. Aka one quad is one pixel, so imagine you have one rasterized picture in photoshop and scale it up until you see the individual pixels on the picture and it looks ugly right? So the lower pixel density (blue color) the bigger the pixels are which leads to less details in shadows and/or shadow artefacts. And other way around, the more pixel density you have (orange/red) the smaller the pixels are which produce more details and less shadow artefacts.

The difference in color you see is because your uvs arent completely 100% stretched out, but if its that small difference in color its not a problem. Your problem is the ligthmass settings.You have **Static Lighting Level Scale **on 1 which will not produce good results. Also you need to build light in production quality (check screenshot).

Try with those settings:
Set the build lighting quality on production (check the sceenshot)

Lightmass settings (check screenshot)

Static Lighting Level Scale: 0.1
Num Indirect Lighting Bounces: 5
Num Sky Lighting Bounces: 5
Indirect Lighting Quality: 1 (Max 4)
Indirect Lighting Smoothness: 0.6

And UV resolution on 512 (the color should be orangeish/redish).

LIFE SAVER ! :smiley: so i just put static lightning level scale to 0.1 and immediately solve problem :DNow i have small twitch to do and i think it will be ok thank you very much. My ignorance to lightmass settings cost me 3 days of work on nothing xD anyway do you know how to solve this table problem it bother my eyes?

SOLVE!
cranking up resolution delete this stupid connection line :slight_smile:

You can fix this by just raising the lightmap resolution, if the colors are blueish/greenish it means that the resolution is too low. Could you post a sceenshot on how you have laid the uv islands?

bigger table and smaller table map3.png

Nice! Just be careful with the resolution, use max 1024 and in some rare cases 2048. Bigger than this is just unnecessary overkill and it would mean that you need to split the mesh in smaller parts. :wink:
Good luck with your project! :slight_smile:

that is overkill as I can see and build time went sky high on 1024, 512 give very good result, and 128 minimum and 256 optimum as I can see on other projects. Have to update my GPU units so I can make better and faster renders, also green color is what we need on lightmaps density because red takes too much computing power, so you use big resolution just where you really need it, and blue gives you shade artifacts. https://docs.unrealengine.com/en-us/Engine/Content/Types/StaticMeshes/LightmapUnwrapping#levelviewport