Download

Problem with uploading mod

Hi, im quite new to the Dev-Kit. On a request from our Server i have tried to get back the Christmas lights as a mod.
So i have copied all files (Blueprints, model, textures, materials) to my modfolder edited crafting requirements and the engram.
I also changed the material used by the model and the textures used by the material to the ones copied to my folder since they dont exist anymore in the game.
I have added the xmas lights to the primal game data under additional engrams and additional structures to place.

Inside the dev-kit everything works fine and the mod is cooked without any problems.
After cooking the mod i uploaded it to test it but only the blueprints and the model will be uploaded but not the material and texture.
So ingame i can craft and place the xmas lights but they are not textured and appear as a simple grey model.

So how do i get the material and textures to get uploaded with the mod and what went wrong?

You mentioned the primal game data did you also create the new game mode? Not really sure just from what is posted, but I do know you don’t have to copy to existing textures into the mod. If everything is referenced correctly it will pull them.

Sounds like you are pulling the material references and such from the existing game files on the dev kit. I would make a copy in your mod folder of the meshes, materials , and ANY and ALL texture maps that the materials use. Then make sure you relink each of these to your new copies. This will ensure that everything is cooked with the mod incase any of the files are not in the vanilla game content.

Thanks for your replys, sorry for my late answer, have been busy.

@jhawl:
WEll i have edited GenericMod, PrimalGameData and TextGameMode files.

The mod works, ingame i can learn the engram, craft and place the xmas-lights, only the textures are missing cause they are not uploaded with the other files of the mod. Its simply a grey model that is placed.

@IONIC_OVRDOSE:

I think i did, i have copied alle files (mesh, material, texture) to my modfolder, edited the mesh to use the material from my modfolder and edited the material to use textures from my modfolder, linked the Engram to the copied blueprint, Linked the blueprint to the copied mesh and added it Engram and blueprint to PrimalGameData additional Blueprints and Additional Structures to build, but the material / Texture wont be cooked or uploaded :confused:

So i dont know what i have missed.

If you look in your mod download folder from steam does your textures show up there?

@jhawl, no, the textures are in the project folder in the ark dev-kit, but not in the mod-folder in ark, so it seems they are not cooked / uploaded.

For a texture to be cooked and uploaded it needs 3 things.
To be in the same mod folder as the mod.
To be referenced in a material, IN the mod folder.
To have the referring material referenced in a live active mesh component IN the mod folder.

If your mesh is grey, either it’s material reference was de coupled (can happen automatically at any time)
or
The material it was referring to was not uploaded, may not have been IN the mod folder, you may have altered a base mater.

@Akukiyo

Thanks for your reply.

I have copied the Mesh, the Material and the Textures to my modfolder.
Then i have opend the Mesh and changed the Material on the right side (The Sphere that preview the Material) to the Material from my Modfolder (Mark the material file and clicked the arrow to add the material) If i hover my mousepointer over it, it shows the path to the material from my modfolder.
After that i have edited the Material and changed all textures i found (on the left side where you can add Diffuse, Emitting and other textures) to the Textures i have copied to my modfolder.

I dont know it this is the way you have to do it, but i did it this way when i added my own moddel of a bed and there it worked.

If you want to edit a material/texture you have to supply them.

If you don’t want to edit them, and they aren’t uploaded, there was a decoupling. Could of happened from an accidental edit, or it could of happened from a crash.

You can have your own models that use the game assets materials without supplying them in your mod, they just have to be linked properly in the static mesh.

WEll i think best bet would be to start from scratch and try again, will report, thanks for your help

Did you say you edited them then copied them? After you make a copy the links will all be wrong so you need to re-link the new copies to the correct files. including between each other. So double check EVERY connection.

Hi,

first i copied all files (mesh, material, texture), then i edited the mesh to use the copied material and after that i edited the material to use the copied textures.