Download

problem with unreal engine compiling project in c++

So before few days I posted a thread :
My version is UE 4.13.2 I launch it through Epic games (the default way). I installed vs 2015 with its toolchain and used custom install . I have windows SDK 8.1 , I m on windows 10 . When I try to open my C ++ project it says Missing [the project name] Modules : The following modules are missing or build with different engine version . Would you like to rebuilt , if I say “No” obviously nothing will happen , so I press “Yes” , when I do so it says [the project name] could not be compiled . Try rebuilding from source manually . Tried many solutions all from forums , tried even reinstalling UE . Nothing helps . Please help me , I want to work with your engine :frowning: .

Product Version: UE 4.13

And it was marked as solved , and I was not able to find it even in posted threads in my account , I m still experiencing the problem , I have the info asked and now I m posting what have I done .

Hello , I did not got you entirely , so what i did was :
Got in epic games , opened unreal engine
Got in projects right click on my project > show in explorer
it got me in unreal engine project file > right clicked it >
generate visual studio project files (in order to get to the error log of vs 2015)>
opened the solution>under the folder solutions i clicked on [project name].uproject ,
i must say the file was outside the slns folder , just below it
here it is the log in .txt file
Thank you in advance .

I experienced the same problem before. I don’t remember how I fixed it, but try clicking on the compile button besides the play button in the unreal editor.

I think that normally happens when your project was built using a different version of the unreal engine. In my case, my project was created in 4.11 and I later upgraded to 4.13. So the project modules were from a different version, and recompiling the project did the trick if I remember correctly.

But I have only four buttons : top : Refresh and Marketplace ; bottom-right : Browse and Open . No compile buton . Am I missing something ? Please help me I m completely new to this engine .

I’m not sure where you’re looking at but it looks like this on my system:

3c084894f41ad96c974fe01c4f89784aea515975.jpeg

As you can see, the compile is beside the play and build buttons.

It does not lets me to this screen :slight_smile: . It closes at loading the project . It can not load the project

I see, in that case you need to find the project folder on your computer. It will contain a Microsoft Visual Studio Solution file with a .sln file extension. Open that using visual studio community edition and then build the project from there.

If you do not see the .sln file, try right-clicking on the .uproject file and select GENERATE VISUAL STUDIO PROJECT FILES…

teak