Download

Problem with the launcher update from today...

The launcher installed the 4.2.0 to 4.2.1 update at least 6 times now… if I close the launcher and restart it, it says I have 4.2.0 and it needs an update again…

Even tried Admin Priviledges, same thing… Restarted 4 times, same thing…

8th time now:

Shows 4.2.0 on left; 4.2.1 on right… closed and it shows 4.2.0 again…

I don’t think you did admin privileges right when that didn’t work.

Assuming Windows 7 or 8:
Turn off anti-virus.
Quit Unreal and restart your computer (important!)
Verify that anti-virus is still turned off.
Right-click on the shortcut you use to start the launcher. Click the Compatibility tab. Click “run with administrator privileges.”
Apply and save. The icon should now have the administrator shield icon.
Now, double-click that icon. It should ask you whether you want to allow the program to make changes to your computer. Answer yes.
Now, download and apply the update. Wait until it’s done. Then quit, and start the launcher again.
Now, you should be running the new version. At least, this worked for me and anyone else I’ve talked to.
(Note: The left seems to have a typo; it always says 4.2.0; the right says 4.2.1 even after restart, which means the update worked)

I manually removed the 4.2.0. (which was back again this morning) and then downloaded the 4.2.1 UE4, and now its all good… /shrug

but i do have to agree about the Antivirus being turned off, there have been many times where it has been a problem (every time i compile an exe from code it wigs out)

I do have a suggestion to the devs, allow folks the ability to change the drive where the launcher and engine save their log files and junk… my main drive is a small SDD my data drives are raid with plenty of space… i have to do a lot of housekeeping with the launcher shrapnel to keep my drive clear of junk logs, etc…