Problem with textures wrapping/bleeding during import

Hello! I was messing with decals to create wires for my game, and came across a little problem…
Is there a way to easily fix bleeding from the edge of decals? My decal material wraps around a little bit when I don’t want it to do that… (Looks quite bad in game)

Example Pictures:


Hmm, i don’t click imgur links, thay have had problems.

However, decals ar projected directly onto a surface, so i’m guessing there is some rounding of the surface that isn’t a decal, that would be projected on, by the decal? Or could the decal but slightly larger than the surface of the geometry being decal-covered? You can adjust the size of the decal, but usually decals havea problem with stretching on angled surfaces.

You would need to vertex-paint the mesh, if angles>15-20 degrees are present, depending on how accurate you need the decal to be. In the case of a wireframe overlay, it would be best to vertex-paint the wire material onto the angled surface, rather than using a decal, because vertex=painting adjusts to UVW Maps, not just a projection.

Also, if you bake a SpecularMap for eg. in a 3D app, using the wires in greyscale and then editing the greyscale to reflect the color scheme you need, that could work without the tediousness of guess-work. Just using a modifier to generate the wires would be a question: “Which Modifier?”

if 3ds Max, Lattice Modifier does wireframe style geometry modifications, so using Lattice to build the wireframe, even with the knots, the modifer’s thickness should be set low, and then generating wires from Lattice, and baking out that Specular, would give you an editable wireframe of the mesh, but if you know of something already, that’s just off the top of my head.

So I might end up using vertex-painting for this instead. I am using a completely flat surface to project these so I do not think its an issue with the mesh. After spending some time working on this issue, it seems that Unreal is importing images slightly wrapped by one pixel, which does make a difference with glowing objects. I’m using default import options. Is there a way to fix this?

(Hopefully you can see these images, new to the forum so not sure how the photos work :slight_smile: )

If for some reason we cant figure this out then I will probably start painting the objects like you mentioned, Decals would just be much easier to work with since they are just images projected onto other objects.

it may be a small stripe in you alpha mask. i would use an image editor, and zoom up close, and scan the texture(s) in question.

[edit] i see the mask now, yes it is the mask causing those stripes, you can select the stripes and paint over in black and they won’t show up in the color sample anymore.