Problem with sRGB

Hello, my Editor Utility (UE4.24.1) for Texture assets is working very well on preparing MetallicRoughness textures from Substance Painter. It sets the texture to Mask no sRGB, sets the Composite channel to green and adds a Normal map with a matching name. Only the funktion Set sRGB does the job not right. Indeed it sets the Checkbox to OFF, but this has no effect until I open the Texture in the Editor and hit the Checkbox with the cursor. So I wonder if there is any “update” or “refresh” function I am missing, or if this is a bug. Also I wonder why sRGB does not atomaticly is unchecked when setting compression to Mask no sRGB. Does anybody has an idea how to fix this? Thanks and regards

same… has this ever been fixed?