Download

Problem with showing ads.

Hello,

I have followed this guide https://docs.unrealengine.com/en-us/…ms/Android/Ads and hasn’t missed a single step, except that i didn’t fill in the Game App ID and Google Play License Key because i’m not publishing it on play store, and as far as i know and read from some forum, Admob allows other app store such as Amazon to get ads from admob. And yes i did add the com.android.vending.BILLING.

So the problem is that i don’t know if the ads can show without publishing the game into an app store, i packaged the game and downloaded it on my android (With Wifi ON), but still nothing, it doesn’t show ads.

I too tried to use the Admob’s ads tester, but unfortunately, it doesn’t work too. (Does it works?)

1.Any idea? Do i have to do more things other than following the step of https://docs.unrealengine.com/en-us/Platforms/Android/Ads? Or do i have to publish my game first?

2.Does the ads tester from admob works?
NOTE: I ONLY use the Admob Network from Admob, so i think, i don’t need to download any SDK and import it to UE4, right?
NOTE2: This is for other app store such as Amazon, Aptoide, etc. And i will repeat what i say and read from another forums: It says that Admob can show ads even if the app isn’t in Play Store.
NOTE3: In my Blueprint, this is what i did: Load Interstitial - Is Interstitial Ads Available - Branch (True) - Show Interstitial Ads. So i think there’s not problem about my blueprint.

EDIT: For new readers. This is my blueprint to load adsbp.PNG[Abrir el nivel] is [Open Level], the [Proyectar a MainMenuGameMode] is [Cast to MainMenuGameMode] (There’s nothing special in the Cast, since i followed a guide from UE4 and another video but i think there’s not need for it), then it proceeds to load ad. This blueprint is called when i click a button from a widget. Is there any problem with this blueprint, so that is because i can’t see the ads?

Thanks for the answer and sorry for too many questions.

It would be good if you could attach logs from your device when you try to load ad.

Hello, thanks for the answer.

At first I found the log in my device (android) but saw that it’s too long so i delete it, but unfortunately, i thought that when i play the game again, it will add another log (I even tried to redownload it again but nothing), but nothing happened.

NOTE: this time, i’m using my real admob unit.

EDIT: I removed what i said before, this is the log: ads.PNG
ads3.PNG

I’m getting a problem that i don’t know what is happening,

In my admob account, it says that i received 4 ads (With not profit and nothing), but in my game i can’t see an ad showing.

NOTE: I’m using real ad unit.
NOTE2: I haven’t published my game yet.

Any idea?

EDIT: For better understanding, this is my blueprint to get ads, bp.PNG
[Abrir el nivel] is [Open Level], this blueprint is called when I click a button from a widget. It will open the level, then proceeds to load interstitial ad. Is there a problem in this blueprint?

Thanks for the answer.

Hello, Did you get solution ?

Bump- any answers on this? Was this ever solved - looking for help on why my banner ads are not showing up (first time using admob integration)

Same here…

Ok, followed the instructions on this post: Integrate Google Play Services with Blueprint - Unreal Engine Forums

Working now. Not sure if that was the issue or not, as I have tried so many things, that its just now working so I’m good. Please see above post and make sure you turn the APIs on mentioned for your particular app. Note, I think Google Cloud User Accounts is no longer valid, as It doesnt show in the choices, but ads work anyway. Best wishes!