Download

Problem With Shadows

I have some issues with shadows within my project. I did read somewhere that this is due to overlapping BSP/Meshes over one another which can cause the issues in the screenshots of my map below.

&stc=1

&stc=1

&stc=1

&stc=1

You can see in some areas that there are shadows leaking and sitting in the incorrect places. I did try making some BSP not overlap my wall meshes but I still had the same issue in the same area’s of my map. I don’t know whether this matters but none of these meshes have physics. The lightmaps are at 64 resolution. Any help would be appreciated :slight_smile:

Your lightmap resolution is too low and you need to make sure that walls aren’t just a single plane, you need to build the inside of the wall and the outside of the wall like it has thickness. Also make sure that the floor/ceiling/walls don’t extend beyond the corners, this is because sometimes the edge that sticks out can receive lighting and it might bleed onto the interior.

The walls have a thickness of about 5 cm. I removed the side polygons, less to UV :P.

I can boost up my lightmap res a bit but I don’t know if that will solve the problem, I will give it a try.

As for the floor it is all one BSP brush which does extend beyond the corners of the walls, I think if I make a floor per room that might solve my problem. I’ll give everything you mentioned a try and see if it fixes my problems.

Thanks darthviper107 :smiley:

If the floor is BSP you need to lower the lightmap resolution number, the way it’s blobby and got the rounded corners means it’s too low resolution. With the lightmaps it processes it to make the edges of the shadow nicer instead of looking really pixelated.

To critique a bit when establishing your lighting base go big and then back things down to something that’s a bit more reasonable and trust your eyes are telling you the truth. By default most applications will be set to a default that’s not even close to what it should be to produce the kind of result your looking for.

If it takes a 1024X light map to get the job done then that’s what it takes.

Using the default materiel is not going to work well as UE4 uses physics based materials and lighting that works in tandem with on another. A light trace is projected from the point source that when it strikes a material surface tells the light compiler how light needs to bounce off the surface based on it’s properties. Light bounces off a metallic or plastic surface a lot more than it should off a mat surface so if you make all your walls metal light should bounce like crazy.

With out a material to process you land up with what you got where light goes splat and there is no real bounce/renderosity effect occurring.

Last observation you have way to many lights and trying to flood an area based on the assumption that they are actually real lights and like baking a cake you need a few more ingredients

First observation lights are not all white but contains a mix of diffused colors based on the kind of light it is. Add a touch of tint like a yellow or orange, and as in a little is a lot, you will get a softer light that does not look monochromatic. Next you will need light(s) to act as a fill to paint the canvas so to speak by turning off inverse shadowing of a single light with enough of a level to see but yet still difused. From there you have your base lighting that you can added or remove point sources as you build up the environment.

The standard lighting setup used is called Three point lighting.

http://en.wikipedia.org/wiki/Three-point_lighting

Rule of thumb in a physics based edit environment is less is better and with the right mix of helpers and materials you should get a much better result by trying to force lighting using 6 point sources in a given area that does not serve any other purpose.

Thanks for the advice FrankieV. I’ll play about with the materials when I get more models in there at the moment its a bit bare because it’s just the base of my level in there. All the walls are modular and I’m using substances to texture. In regards to the lighting, the only reason I have so many is to see what I am doing :stuck_out_tongue:

Still having problems with this :frowning:

I have managed to get the shadows looking good after playing with the lightmass settings. But now I have seams where my modular assets meet.

&stc=1

&stc=1

&stc=1

I have managed to fix the issue with the shadows though. Here are some shots, I am pretty pleased with the results :smiley:

&stc=1

&stc=1

Really need some help with this though it is driving me mad. The floor is different BSP brushes, I changed the floor so the BSP brush doesn’t overlap any corners or edges of my meshes.

Also, I should mention this map has been built in 4.5 and the lightmaps have been generated from UE4. I have also re - made the modular assets and added thickness to them because the old models I made I deleted the side polys from them so they looked like they were planes on their own, but I’ve made them again with the polygons there and UV’ed them again.

Butt one modular component to another your probably going to get a seam created by ambient occlusion.

I don’t know if it is the UV’s or the lightmaps. Like I say UE4 generated the lightmaps (used the new feature on import with 4.5). This is something that I can’t seem to get my head around and it’s killing my project completely :frowning:

Here is a screenshot of one of the modular walls in Maya LT.

&stc=1

In my previous post (the one at the beginning of the thread). Those shots from UE4 where with the same modular assets I made in Maya LT, the only difference was I removed the polygons on the side of the models (in the shot above I have selected the polygons that I removed.) With all those side polygons removed and the models UV’ed I had no seams.

If you look at the first batch of shots I uploaded here the walls are seamless, I don’t know whether it is because I had removed those side polygons or whether it is something else in that previous project I had changed to get the walls seamless. As you can see though in the screenshots above the modular assets I re - made I kept those side polygons in there and now the seams are really bad on the walls.

I don’t know if it is a good idea to remove the side polygons on the models and whether it is common to do that, or whether I should keep them. I don’t know if removing those side polygons will affect the way the lights work in the level. I really need to get this fixed, it is completely killing my project and slowing me down on other things I could be doing :frowning:

I am more than happy to share the asset’s the project, whatever it takes to getting it fixed. I want to know what’s causing it so I can learn from it and make sure to avoid doing whatever it is that is causing this.

Right now I don’t know whether it is my lightmass settings or whether it is my model’s or the UV’s. The more I think and try to fix it the more confusing and frustrating it gets lol.

If it’s a static model then it might be a smoothing group problem.

Primer - YouTube

So yeah more than one side could create a seam.

It is a static model. All my Maya LT export settings are default. I will have a look though, when I import into UE4 I don’t get any errors about the smoothing groups of the models.

Smoothing groups is ticked in my export options in Maya LT also.

I think I have got it sorted now. I still have no idea what the problem was/is though and I don’t know whether this has fixed it properly. I have made the models again. UV’ed them but this time I didn’t ‘move and sew’ the side polygons onto the main face. The results are this!

&stc=1

&stc=1

There is actually 3 modular walls there.

&stc=1

&stc=1

Light that hits the model the most the seams aren’t visible at all. The back of the model where hardly any light reaches is what tends to cause issues and makes the seams a little more visible. I tweaked the lightmass settings in world settings to try and hide the seam’s even more. I have no clue what causes this. I don’t think its AO though because when I switch AO on in the lightmass settings the seam’s were barely visible and the results were even better.

I think this might be a UV problem, like I say I didn’t sew together the side shells/polygons to the main shell/polygon. Here is a shot of the UV’s. I have mirrored the majority of the shells to get more texture space.

&stc=1

As you can see nothing has been sewn together and it’s made a big difference in hiding the seams when building lighting. I don’t know if this is the problem and I can imagine I’ll run into this issue time and time again throughout my project :frowning:

@FrankieV. Youtube is not working for me right now for some reason so I can’t check out the video you recommended, when I get more time and when Youtube works for me I will check it out :slight_smile: