Download

Problem with setting Transform for player pawn

What I’m trying to achieve is to set the transform of my player pawn to a previous transform. So I tried to setup a quick little system to test this (see photo).

To clearify:
when the player presses F the current transform of the player is promoted to a variable, and an actor is spawned using this transform to be able to check if this system is working.
So after the player moves, it should move back to the stored transform by pressing M. But instead of actually being moved back to that transform it seems like the player just moves back a bit. But when I keep spamming M it seems to eventually end up with the right transform (see video). I don’t understand why this is happening because for as far as i know nothing is wrong with the blueprint.

I have been trying to figure this out all day but I still have no clue what is causing this problem and I’m starting to get frustrated. So any help is welcome.

Video:
https://www.youtube.com/watch?v=gGNinRcw6-I

Thanks for responding! I Changed the GetRelativeTransform and the SetRelativeTransform to GetActorTransfrom and SetActorTransfrom like you said, but unfortunately that doesn’t solve the problem. The same thing happens :frowning:

There is no way for the ball to move because it’s stationary and the physics are off (see photo). But to make sure I still looked in the world outliner (see video).

https://www.youtube.com/watch?v=6qur4MTS2h4

As you can see the ball is not moving.

Okay so I checked if the Ship is centered inside the blueprint and only the Z value wasn’t equal to 0 (see photo). So I changed that to 0 and then tried, but nothing changes.
And yes, the whole pawn is moved when moving, not just the ship part but the whole thing.

Yes I think you are right, the forces could be affecting it, but I also have no idea how. so I made screenshots of the movement system. (see photos). Maybe it has something to do with that?