Problem with rotation of bone with transform bone node

Hello. Im am rotating the spine01 with the use of Transform(modify) bone in the anim graph. when I press the left mouse button it rotates and when I release the button it sets back to zero by the use of alpha = 0. But when I turn my character and press it again, the bone turns to its last rotated position. How can I set it back to zero of the actor or the controler so it dont look wierd when I turn my character?
Here is my setup:

Could this be a rotation space issue? When you click on the Transform (Modify) Bone, in Details is the Rotation Space set to World Space rather than a Bone Space?

1 Like

It is set to world space

Okay. I think you might want to try changing that to Parent Bone Space. Also, depending on your rotation on Spine01 required you may actually be looking to set the x (roll) of Spine01 to actually make the torso yaw left and right, with Parent Bone Space set.

I tried setting the rotation of transform to parent bone space but it still the same issue with the weird rotation when I press the mouse button again after turning.

… You actually have to store the initial value, and then re-set whatever variable you use to the initial value you stored…

Alright, I tried that with GetSocketRotation node at begin play, then setting as rotation that after mouse button is released. But it stayed the same. Maybe there is another way?

I’m guessing that if it stayed the same the variable isn’t applied correctly?
Triple check on that, even just set the alpha to 1 consistent to test…