Problem with retargeting, no preview mesh

Always getting an error that the skeleton needs a preview mesh, with this pack Giant Monster Animset in Animations - UE Marketplace

Saved ref pose, saved animation preview images (were also missing).

Is this a 4.14 issue, pack only updated up to 4.13. But normally no problems with UE versions and animations,

I have the same problem but I hope some one who knows can answer soon.

In 4.14 you have to make additional step if you want to retarget animations: - YouTube

Thanks, this resolved the problem.

What version of engine are you using ? Still 4.14?

They are having this issue again, but it isn’t fixed, both of my skeletons have preview mesh. and it is the on that I am attempting to retarget that isn’t showing up this time.

I’m having this issue on 4.18

So your solution was to re-target in exactly the same way you’re supposed to re-target?

1 Like

Lol, dudes, you both made my day!

Actually if your animation (skeleton) lacks a preview mesh while retargeting, you:

  1. open skeleton asset

  2. click preview mesh

  3. click on a mesh

the message will appear and the bottom right: “This mesh is set temporarily…”

  1. click apply under the message

  2. save skeleton


I was having the same problem in 4.24 (And I’m guessing that you are not having problems with bone names, since it just asks for the preview mesh). This is what I did:

  1. Open Skeleton Asset;
  2. Repose Skeleton Asset;
  3. Click on the “Apply” button under the Mesh section of your preview scene settings (Far right of the screen);
  4. Save the Skeletal Asset;
  5. Retarget Animations.

People are not actually applying the new pose so while it “looks” like it is changed in the preview window when you save it, it actually isn’t saving that new pose for the animation instances, just the preview that you are seeing. So just make sure to click the apply button, or it will not work.
Also, if you go to retarget and you do not see the original asset mesh (nothing in the first box) then this is actually telling you the pose was not applied.


This. This solved the issue for me.

same issue 4.27

The issue was present in 4.25

It works! Thanks!

Just in case, this retargeting is here: open skeletal mesh → skeleton tab → click „retarget manager“ → appears new tab on the left, add new (choose your skeleton) → select Rig „Humanoid“ → AutoMap → ModifyPose → and really important step, on the right switch the tab „Details“ to „Preview scene Setting“ and apply there new skeleton rig

It should work now and you can switch one SkM to another