Problem with physics bodies not translating properly

I have started making a whip-like weapon, one that can extend in certain situations. Since I am using a plugin developed by Rama which makes extensive use of physics bodies in the PHAT tool, my weapons all need to be skeletal meshes. For that reason, I am trying to get the extending bit to work by animating bones.

Right now, I am using a sword for testing, whose blade I have divided into 4 segments. The yellow cubes are the physics bodies.

To test the extending bit, I have simply used scaling to animate the bones in 3Dsmax. I have had no problems exporting the animation (as long as I kept “Resample all” checked in the FBX exporter) and the animation works well in the editor too.

The problem is with the animation of the physics bodies. While the physics bodies inherit the scaling of the bones, their position remains the same, resulting in 4 overlapping physics bodies that don’t even get close to covering the entire length of the sword:

How can I set up the physics bodies to take into account not just the scaling, but also the translation of the bones? If there’s no way, anyone know of an alternate way to create a skeletal mesh whose bones can extend in length?

I am having exactly the same problem! I am creating a character customizer. Some parts of the base mesh are physics enabled, like hair, belly, breast etc… I can scale them, but I am not able to translate the bones with enabled phyics. They just snap back to the original position of the physics body.

Here’s a video demonstrating my problem:

Edit: I actually fixed this by adding helper bones before the breast bones in the chain, set those to kinematic and applied all transformations to those.