Problem with New Level/Can't move, camera falls indefinitely

I don’t think so. I did add a main menu widget to the test level’s bp before I tried adding any new levels, could that have caused this somehow?

I’m actually not sure how to really title this since I’m not sure how to even properly describe my issue, but I’m having a huge issue whenever I start a new level.

I’ve got all the collisions properly set up and everything (I think), but I’m having this problem where every single time I make a new level, regardless of if it’s a new blank or default template, whenever I press Play one of two things happens: I’m either forced into some kind of first person perspective (I’m creating a 2D sidescroller so this is weird) and can’t move; or my camera seems to be locked on wherever I was looking in the viewport and it just drops until either it falls out of the world or hits the ground, and I still can’t move the player.

I have a separate test level that works perfectly fine, but for some reason creating a new level seems to break things? The first person perspective happens if I only have a Player Start, and the camera falling seems to happen when I don’t have a Player Start. Putting a playable pawn in the level doesn’t change anything.

Can anyone explain what’s going on, and how to fix it? If I need to explain it better I’ll try.

Did you change anything in the game mode by any chance?

Ok, if you click the down arrow on the play button and choose ‘from current camera location’ and then you can try right clicking somewhere in you level and choosing ‘play from here’.

I’d also take a look at your level in collision view mode to see if the collision on things are as your expect:


I’ve edited the blueprint, but only for animation changes and a small interaction system.

Checked the collision, tried “play from here”, and it’s all the same problem. I even double checked and it looks identical to how it’s set up in the test level, where things work just fine. Is there anything else that could be causing issues that I should check?

Is this a default player, or have you edited the blueprint?

Sorry, maybe not the best question.

I’m assuming you have a third person type pawn in the level, but you also have a camera facing the level - side on.

Is that correct? ( like the UE template ).

Also: are you doing anything in blueprint, like possession?

Sorry, I don’t know what your setup is. You have a camera facing the level ( is that set to possess? ). I’m assuming there’s a camera in the pawn also ( which you don’t use until you have this problem ).

Hello everyone! I have the same problem. I make a 2D game in a 3D environment. I made my first level correctly but when i try to open a second one and try to play this level, the point of view in edit mode falls endlessly, and I think it’s not the main camera. This camera is on a spring arm in front of a capsule component (there is a paper flipbook in). more than that, i can’t move my character. What is the problem?