Download

Problem with NavMesh - How can I troubleshoot? NavMesh just not turning green when pressing P

Hi Guys,

I ran into a problem with getting the NavMesh to show (working) in my game when pressing P. I’ve pressed it so many times the key is about to pop off of my keyboard!

My Setup:

  1. Persistent Level with 3 Sublevels.
    2.Landscape is on the Persistent level
  2. Placed the NavMeshBoundsVolume on the persistent level.

When I press P to make it turn green, nothing happens. I’ve restarted the project several times without success.

When creating a new project it works.

Is there a way I can troubleshoot this to find what is going on?

THX!

Does it intersect with anything in the level ? :slight_smile: May not show because it’s not actually overlapping with any navigable surfaces? Have you tried “Show Navigation” from the viewport menu? Or just the ‘P’ key?

I’ve tried that. My Landscape has Collision set to “Block all” and pressing “P” or “Show Navigation” doesn’t work. I must have something in my level which is interfering with the Nav Mesh.

Does anyone know a way how to trouble shoot this to find what is keeping my Nav Mesh from working?

THX!

SOLVED!! --Haha, that feels gooood!

For some reason I had “Generate Navigation Only Around Invokers” selected in the Project Setting under the “Navigation System” tab. Deselecting it makes the Nav Mesh work as usual.