Download

Problem with modifying the Advanced Vehicle asset fbx. file ( adding custom mesh)

Hello guys,
I wanted to import my 3d model of a buggy inside UE4 so originally I wanted to create everything from scratch but after 3 days and endless re-runs of the vehicle blueprint tutorials on Youtube I gave up( my vehicle worked only partially even after following every instruction in them multiple times). So, finally I decided to import in 3ds max the original asset fbx. file available for download ( vehicle_proto_S2.9) and just attach my mesh to the existing one without interrupting in any way the bone hierarchy ( i added edit poly modifier above the skin modifier, left a few faces of the original tires so the mesh doesn’t lose any rig info and attached to them my tires ,and attached the body of my vehicle to the buggy armature, also made sure to move again the Skin modifier at the top of the stack)
But when I tried to import the fbx in UE4, it gave me the following messages :frowning: and i followed the instructions about the fbx import options form here : https://docs.unrealengine.com/latest/INT/Engine/Physics/Vehicles/DoubleWishboneVehicle/index.html ,so I’m pretty sure that the problem is not in the fbx importer of Unreal, but in the Fbx exporter in 3ds max)

23df4dd3e66e5ce7a1452041fd1af884c6423acf.jpeg

at first i decided that the problem is with the modifications that i made ,but then i decided to just import and then export from max the original unmodified vehicle_proto_S2.9 fbx file to see if i’ll get the same error when import it in Ue4 ( Yes - it showed the same error about multiple roots) My fbx export options are the following :

b9ee47b08e65b0243497421c2d34daf6b58577b2.jpeg

Please, if any of you know why the fbx export from 3ds max messes up even the original working fbx asset file, tell me ( i tried selecting and exporting only the root bone and the skinned mesh, etc) I’ve read in some forums that sometimes the fbx exporter creates additional root bone to the mesh that messes everything up , but nobody seems to know how to fix that )

Hi!

Problem is similar names top hierarchy dummy in scene and car mesh name. Both have name vehicle_proto_S2_9. Just rename one of them and export to FBX. And second problem - after import to 3DS MAX or MAYA, some bones chage orientation. When you import object in UE4 you need check option in “FBX Import” dialog Use T0As Ref Pose

i’m not going to laugh as i haven’t checked the mesh, but if its been exported from the engine it will have an extra root bone named as the mesh. also make sure you have a single root bone/object

next thing once you have your vehicle in engine i advise to check the size/scale against the “Epic Blue Man” , i recent help a guy that had problems due to the fact his vehicle was the same size as the advanced template and it didn’t handle well for him

as a quick tip check any ut2004 vehicle tutorials (content +rigging) as the setup is very similar or UT3/UDK but remember the root bone location (0,0,0) and the scale

I do not know, why this happening, but if import to UE FBX from tutorial link, it import without problem. But if FBX import to MAYA or 3DS MAX and export to new file and import this new file to UE, we get error.

sorry for the life of me i can’t find that asset so i can’t say what might be going wrong

Just thought i would add this in to a question that don’t look like it was answered, and for the people that find this in the future looking for the same.
I have actually come here looking for an answer to a problem after getting the skeletal mesh back into the engine, ANYWAY, I was trying to get the advanced vehicle out of UE4 to Blender then edit it and imported back into UE4, BUT kept getting the same Multiple Roots found error, No matter even if i just imported into, then exporting without changing anything at all ?,
So it did seem like Blender was adding something.
But after trying to delete this and that and every kind of importing/exporting configuration, AND Days of searching, I found someone (can’t remember who, and at the time thought his/her
answer didn’t sound like the answer, but thought i would try it later kind of thing), He or She mentioned something like, Have you checked your 3d editing program is SET to METRIC And not IMPERIAL ?.

So lo and behold later i thought of checking Blender (Haven’t done much with Blender yet :slight_smile: And yes it was not set to Metric, So changed it and only exported the armature and mesh like loads of people here tell ya too, And it worked, No more multiple roots error, So Blender and probably 3ds max ect Don’t add an extra root bone and nor does UE4 Add on export like i have read too.

I hope that helps someone out there ;), And after finding that answer and working out that you have to import it scaled up to avoid the wheels sinking into the ground problem ?, I hope to work out why now the car is the scale i want and sits on the ground properly BUT now it seems (From my very limited knowledge) like the vehicle component is still the original size and seems to need scaling up ?, Because the wheels seem to be going at a different speed to what the care is going Plus the turning circle is alot smaller to scale of the car (car turns in a smaller circle to what the wheels could possibly be turning the car in ??)

Anyone ? :slight_smile: