Problem with launcher versus play

When i run my game via the launch button, it loads incomplete and outdated versions of levels(only 2 at the moment). When i run it via play, it runs everything up to date. I can’t seem to figure out the cause and im hesitant to continue development until i fix this.

Try using the cook for windows utility from the file menu. It cooks everything pretty much like packaging the game.

Just tried that, yielded no results

Ok so i found a solution to the problem, even though i still don’t quite understand the cause.
The main issue lied in attempting to load the level from a button on the main menu. The level would load normally if i started launch on the level, however when returning to the main menu then trying to load the level in question it would load an incomplete version.
For now the solution is… anytime i change the level the name has to be updated on the level and all buttons and functions calling the levels name.

There has to be a better method than this. Right?