Download

Problem with importing fbx character files from blender

So i tried importing fbx file which were exported from blender. When importing to unreal my root bone seems to have a scale of 100 bec of this my char animation retargeting doesnt work. I tried chaning scale while importing but still it has problems with animation retargeting. Same model i can use it on unity with no problem but doesnt work with unreal.
I tried using mixamo to autorig the char and it has same problem root bone scale goes to 100 for some reason

Any help guys??

Yes, I have workaround for this. Maybe there is an easier way but it works. Basically go into edit mode, press A to select all bones and then deselect your root bone. Then scale all the other bones up by 100. Apply location, rotation and scale using CTRL-A. Now go back into object mode, select your mesh and scale that up by 100 too. Apply location, rotation and scale using CTRL-A again. Now your armature and mesh should be exactly the same size again but 100 times bigger than when you started. You are now ready to export to UE4 using File > Export FBX. In the operator panel you can use your own operator preset but make sure that the Scale field on the Main tab is 1.00, that Only deform bones is unchecked and Add leaf bones is unchecked on the Armature tab. It is also a good idea to set smoothing to Face, which stops you getting the message from UE4 about smoothing groups. Import into UE4, you can use your usual options but in order to correctly reset everything to our initial scale, you need to set the Import uniform scale to 0.01 in the Transform section. If you have done everything correctly, you will not get errors about physics assets or smoothing groups. You can go into Persona, select your skeleton, then click on each of the bones, root, pelvis, spine_01 etc and see with your own eyes that they got the correct bone scale in the Details panel. Hope that helps. If not you can drop me a message, see david smiley on social media.

To fix root scale:
In Blender: go to scene settings, set length to Metric. Set Scale to 0.01
Now select your skeleton and scale it by 100. Now apply the scale.

It really helps, many thanks!