Download

Problem with footstep sfx/particles

Following this tutorial, I set up some foot step sound effects and particles for my project. However, it doesn’t seem to register the type of surface? I have the default of course, and snow. With the default sound set to none and the snow sound set to the footsteps sfx, I don’t hear anything. Putting the sfx on the default surface though works fine even though my character is running on a snow surface. Same thing with the particles.

I’m wondering if 4.26 changed anything about how this works? I’m not very proficient in Blueprints so ELI5? lol

Your first “select” node doesn’t have anything for Default or Snow. That’s all I can tell is wrong, but maybe it is something else that the tutorial covered, retrace your steps. :slight_smile:

Whoops that was my bad when I took a few quick screenshots. I can guarantee that having sound cues in there only plays the Default sound, and on both of my surfaces instead of a different one for Snow. I’ve gone through the tutorial three times. I’m going to go through it again in the morning with a fresh mind though I’m sure I’ve followed all of it to a tee.

Based on the pics you aren’t using the pinned Surface, nor location (Handle Footstep). Surface should be piped to Switch on EPhysicalSurface, and Location used to play sound should be that of the initial trace + Z addition. No need for another trace.

e.g.

Alright so I removed the Select mode and put in a Switch on EPhysicalSurface but I’m guessing I still don’t have it right as the sound still only plays for Default surface.
I’m not sure if it matters that my Snow does have some setup so the character leaves a trail when walking through it.

Dude … Take the Surface pin from the Handle footstep node and pipe it to the switch.

Your surface var is more than likely empty … meaning null, no value assigned. This is because nowhere in your given code are you “Setting” it. You’re simply passing the value to a pin. So use the PIN.