Problem with fly in editor after unposses

Tried this in TopDown Blueprint example.

With editor viewport opened hit toolbar buttons “Play”, “Pause”, “Unpossess”: can’t fly in viewport with regular WASD-right-mouse-button controls.

Uncheck “Show Mouse Cursor” in PlayerController details and I can fly in paused unpossesses viewport.

Is this behaviour intentional?

Or maybe I’m doing something wrong?

If I need to show mouse cursor in my game I should do it some other way? Maybe custom UMG like in here

Thanks in advance.