Problem with fbx animation

I have tried to import an fbx file with animation
which animation preview in the 3d viewer

this file is created in blender 2.8

when I import this file in ue4(v 4.21)

it shows this message

when I open its animation sequence I found it 1% smaller

I want to know the reason for it, how can I resolve this problem?

Well let’s go by parts:

  1. Smoothing groups: The easiest one to solve though it isn’t reaaaally a big problem, when you’re exporting the .fbx, you have to select in the geometry tab the option smoothing to faces.

  2. Missing bones from binding pose: when you export the .fbx you have to check on the armature setting the option to export only deform bones and uncheck add leaf bones, that options add bones to your existing armature and can cause some problems. You also may want to create an action of your mesh keyframed in its rest pose, and called it “aaamainpose” or whatever and export from that action, and when importing checking under the animation tab the Use T0 as ref pose option (the aaa isn’t necessary but I like to name it that way so it forces it to appear at first in the action list).

  3. Small size: you have to set your Blender scene to use the metric system instead of blender units, you can select that in the scene settings on the properties panel. Also check inside that panel that your unit scale is 1.000000 and check in the scale of your mesh that every number is 1, if they aren’t select all of your mesh and go to object, apply scale, (you may want to apply location and rotation also, but that can mess up your object if you have moved it in object mode so be careful). Also, this can sound stupid but Unreal doesn’t like your Armature to be called “Armature” so change the name to some other thing.

And that’s all, test all of that, and tell me how it goes :wink: