Download

Problem with exporting models

When you export a model error:
Head has degenerate tangent bases which will result in incorrect shading. Consider enabling Recompute Tangents in the mesh’s Build Settings.
Work in 3d max file format Fbx help solve problemmu.
Sorry for my English using Google translator)))

Export it as FBX 2013 and dont forget to UV map the mesh before that.

I’m having the same problem with one of my meshes. Its not an issue with exporting as FBX 2013 or 2014 it’s something else. still working on it.

Double click onto your static mesh in the UE4 -> Select the recompute tangents/normals and click save

0e515d086e27070d3b5c63c5cd3499380069e6f4.jpeg

I have this problem with one of my meshes. The UVs are completely laid out, Recompute Tangents is checked. It looks great until I bake the lighting, and then it’s just a total mess. Can’t figure out what’s wrong.

The issue in the screenshot is an issue with smoothing/vertex normals. If you don’t have a problem until lighting is built then it’s either a problem with your lightmap UV’s or your lightmap resolution is too low.

It’s the weirdest thing, because my uvs are laid out completely, no overlapping whatsoever. But when I bake the lighting it says that UVs are overlapping by 94%. I thought of having UE4 generate it’s own UVs for the lightmap on a second UV channel, but when I try it says “Generate UVs failed. Couldn’t convert to a D3DXMesh” I have a screenshot, but it won’t upload for some reason >_<

Hi Enomobile,

Are your second UV’s coordinates set properly? You can check this in the Mesh Editor/Viewer and in the details panel look for Lightmap coordinate index is set to 1. If it’s set to 0 it’s using the texture UV map instead.

If you’re still having trouble, post a screenshot of your second UV channel here. You can view this in the toolbar by selecting the UV tab and then a few buttons to the right change the UV Channel from 0 to 1 in the drop down.

This way we can see if you’ve got a good second UV layout and offer some help. :slight_smile:

Thank you!

Tim

Hmmmm. It seems my second UV channel is a total mess. But I don’t want it to use my second channel (I didn’t even know it had a second channel). How do I tell it to use channel 0?

Open up the static mesh and check Static Mesh Settings on the right side. Click the arrow to see advanced settings and set Light Map Coordinate Index to 0.

You can simply change it from 1 to 0 in the Details panel in the mesh viewer. If you have overlapping UVs in your texture UV (Channel 0) you will still have overlapping UVs issue. This is because there needs to be a channel for shadow information to be baked to. If there are overlapping UVs those UV islands will share the same shadow information which will lead to your model looking strange.

You can always set it to be dynamic if you want to avoid lightmaps but this can cause a performance overhead whereas a good lightmap has zero performance overhead as the shadow information is baked into this texture map rather than being computed at runtime.

Thanks!

Tim

Bingo. You the man, Tim. :slight_smile:

No Problem! :slight_smile:

Glad you got it working!

Tim

problems

desk has degenerate tangent bases which will result in incorrect shading. Consider enabling Recompute Tangents in the mesh’s Build Settings.
image one is what it should look like and image two is what it looks looks like in unreal 4 plz help

Hi Kjethrow,

You’re looking at the mesh in the mesh viewer/editor. You may want to place this in the level, add some lighting, then build lighting to see your mesh as it will appear in game. The lighting in the mesh viewer/editor does not have built lighting so it’s completely representative of an in-game look.

On a side note:

I noticed your mesh does have 5 UV channels. The top of the mesh does look like it’s stretched which will likely cause you an issue as well, as there is a difference between that and the first image.

Also make sure that the proper UV is selected for the lightmap channel. If you’re not familiar with how lightmaps work just ask and I’ll give you some information.

Tim

Sorry to resurrect an old thread, I’ve been hunting high and low for some explanations on this stuff all evening and tried a few fixes suggested in several threads and couldn’t get anywhere. Is there anywhere I can get a detailed guide on this lightmap stuff when used in UE4?

Originally I started with dynamic lights, but that gave me quite some performance issues, so I switched to static and performance improved dramatically. Originally, everything was working fine, but slowly textures began to start turning black. I’ve tried various ideas between generating new uv’s in UE4 and switching the channels, but either they turn back to black after building light or they end up like they have in the picture here:

566c2d5355cacb6c58dddcf13ce566bff3c254ab.jpeg

The meshes were textured using materials built in UE4, so the light map solution I am guessing would have to come through UE 4 (but this is just guessing). Any ideas that could help would be appreciated.

Looks like your lightmap resolution is too low, default is 32 which is too small for what you’re doing. Also, you may have smoothing issues as well, but it’s difficult to see.

You were right in that my lightmap resolution was at 32. I’ve pumped it up to 256, rebuilt the lighting but now it appears even more blocky (can be seen in the next picture on the closest archway / bracer):

556e05fc03f9b3e024dd59ee11cd1903c73cf8e7.jpeg

Maybe smoothing issues as well, I will begin researching into that and seeing what can be done to fix it. Thanks Darthviper, at least it gives me a couple more avenues to explore. :slight_smile:

Probably you havent placed a lightmass importance volume into the level + rebuild the light :slight_smile:

Hi Fighter5347, actually that was one of the first fixes I put into the level after the problems started occurring (and I rebuild lighting after each time I try a new fix as the problems become most apparent after a rebuild). I am starting to think it is a problem with the actual models themselves that wasn’t noticeable until the lighting was changed to static. I had a play around with them last night just before bed and I’ve got a few things I’m going to try at the modelling stage to see if it will solve some of these issues. If I find where I was going wrong, or find a work path that works for me, I will post it up in case anyone else encounters the same issues I’ve had.