Download

Problem with collision settings for static mesh

I’ve created a tunnel static mesh using cylinder brush with 64 sides and I made it hollow, then I’ve converted it to static mesh,
the problem I have is with auto collision settings, it’s blocking the hollow part which is inside tunnel !

Any ideas how custom the collision shape in a way that blocks only the rounded area of the tunnel ?

thank you

Donnut shape global collision and , if you have 64 faces, you’ll need 64 collision meshes, or a less if you want less precision.

To make it the easy way :
Take your cylinder, keep only the center, and extrude these faces as individual meshes to create the Collision meshes.
Rename them and your done.

Here you can see how to create collisions in 3 ways : https://www.youtube.com/watch?v=TTsAYpqHU-c :wink:

Yeah, the basic rules for collision are:

  1. Each collision primitive needs to be a convex shape.

  2. Each collision primitive must be named with a “UCX_” prefix on it that matches the main mesh.

So if you have a mesh called “MyCylinder” in your modeling application, each collision primitive needs to be named “UCX_MyCylinder” for Unreal to recognize it as collision.

The automatic tools inside of UnrealEd are good for some things but for something like a tunnel, I would just do it manually. It will be more accurate and you’ll have less issues.

Also, if your tunnel has 64 sides, you can probably get away with 16 collision primitives or maybe even 12. The lower you go, the rougher the collision gets but it’s expensive to have 64 collision primitives on a single mesh.

For complex concave meshes, you may want to use the ‘use complex as simple’ setting in the StaticMesh Editor for this mesh. This tells Unreal to have the player collide with the actual graphics triangles of the mesh.

I tried this and it worked fine for my player, but overlaps with other static meshes !

I don’t get it !, would you be more specific ?
how do I extrude them as individual meshes ?

Nice tutorial :slight_smile:
I’m downloading blender hoping it work

thank you for this , very helpful :smiley:

The built in cylinder brush is too jagged for a tunnel so I put 64 sides to give it the rounded shape, and yes I’ll put low collision primitives as possible

I tried this and it worked fine only with my player, but overlapped with other static meshes !

Hello again,

Finally it’s working :smiley:
thanks for everyone

here what I did exactly

-I exported my static mesh as .fbx object to blender.
-since I have 64 faces I took one of your suggestions to make it with 16 primitives, so each 4 faces make one primitive
-Select faces you want to copy in blender edit mode,
. duplicate them by pressing shift+D
. I really high recommend not to move your mouse now so the collision will be on the faces you’ve just selected
.press enter then press P button and choose selction from the sub-menu.
. repeat for all vertices
. rename those copies with UCX_ prefix

-export that again to Unreal

  • now if you go to edit static mesh windows you’ll see something like this

-I tested it with other static meshes and here is the final result :smiley:

thank you alot

Well :confused: :frowning:
It keeps overlapping with other static meshes when convert it to a blueprint !
any idea how to solve it ?
thank you

Can somebody help me to make a spaceship hollow?

It was originally a .dae now converted to .fbx

hollow.png

I’m glad you got it to work.
Note that if your mesh is meant to be for something that is not simulated (like a tunnel) you can change the Collision Complexity from Default to UseComplexAsSimple and PhysX will automatically use the vertices of your static mesh. This way you don’t need to export and re-import.

And what is the performance/FPS impact in a normal game with that ? If for example you make a patch of terrain 8x8m in a 3D app and use complex as collision? Or if you create the houses mesh base and set complex as collision ? (Base mesh = something like if you create the main struct of the house with BSP (all cubes/boxes))

Most people say doing something like that cripples your system…but I do it all the time with no problem (I use BSP to map).

However, I have noticed it can lag a bit if you are using multiple complex meshes with complex collision.

Even then you need a lot of them to see something.

It really all depends on the PC.

~ Jason

I personally just use it on some of my meshes, mostly I use basic collision setups :slight_smile:

That’s precisely the workflow I’ve used for most of my work with heavy meshes of scan-based environments, that is concave — interiors —. What could then explain why in the case of certain meshes I’m not getting complex collision? I’m seeing the many faces in purple when editing the mesh, but not in the Editor. Cue: if I enable Show Collision, I usually also see purple collision lines in the Editor, but not with this problem child mesh(s). Thanks for advising.