Problem with cinematic DOF

Ever since 4.23 did away with Gaussian and BokehDOF, I have been fighting with the cinematic DOF to get it to work properly in my game. I understand that it’s more advanced and when it works, it admittedly looks better than the old options. That is, if it works. My problem is that I have no idea how to create a more “stylistic” DOF rather than a realistic one, without making everything either razor sharp or super blurry.

First thing to note is that my game is a sidescroller. The camera is about 1400 units away from the player (arm length).

In the above image, I want to have the DOF like the DOF layer visualization shows; the green and blue areas are blurred whereas the rest is sharp. However, despite the DOF layer visualization showing me the desired visualization, all I get is actually the second image, where everything is razor sharp. For me, DOF has a gameplay function as well; I use it to (slightly) obscure parts of the background the player doesn’t have immediate access to, so the player can focus more easily on the parts that matter.

For the above image, I used a cinematic camera to see if I can get the effect I want. The focal distance is admittedly set to 20, but if I change that to something else I just get an extreme close-up before any blurring of consequence actually happens.

I actually want to either use the normal camera or the post process settings, but due to documentation on those being next to non-existent, I have no idea how to properly set those up. More specifically, if I play with the Lens/Camera settings, nothing seems to happen unless I do an extreme closeup. I also have no idea how the Lens/Depth of Field settings work; the blur amount just seems to make things super blurry or super sharp, and the focal distance doesn’t really do a whole lot either I feel.

Basically, my question is; how can I set up a depth of field that would actually blur the area around my character, rather than extreme close-ups or everything being sharp. How can I actually control the depth of field like I could before?

We are using 4.25.4 for our game and we would achieve the same effect (having a small-scale miniature effect like in TLoZ Link’s Awakening on Switch).
We are running in the exact same issue: impossible to get this effect with standard camera actor (all blurred or no blur at all). Want to have a solution too !

Ok, so after many searchs over the Internet and doing a lot of experiments, I finally managed to get it working for standard cameras.

As it is explained in the [UE4 documentation][1] and in [many][2] [tutorials][3], to increase the DoF effect we need to lower the Aperture (F-stop) value. However for some unknown and arbitrary reasons, we can’t set a value of f-stop less than 1.0 from the Details Panel.


So, the workaround I found is to set the Post Process settings from the blueprint instead, where there are no limitations to the values.

I set a value of 0.1 to achieve the desired effect for our game.


I hope this will help somebody else.

Thank you dude I was looking for a solution for Aperature less than 1.0 for hours