Download

Problem with character mesh simulating physics?

Hey guys. I’m having a slight problem. I’m working on a game where you can enter “ragdoll mode” by pressing R. This causes your character to start simulating physics, and makes him work like a ragdoll. As soon as ragdoll mode is activated though, the CapsuleComponent stops following him. This is becoming a big issue, and I’m not sure what to do. Is there some way to parent the CapsuleComponent to the mesh, so that it will always move with the mesh?

I would try something like that:
c4daa2ea018bec32b0dcdfdfafd2549039e7acdc.png
(Attaching the springarm(camera) to the mesh instead of the capsule)

3b8cf6fc09d2809307b423a21257b0d47eb59a4b.png

There’s what I have right now. I’m pretty sure I have the same thing? The problem here is with collision - things aren’t exactly colliding correctly, and I assume that it’s because of the CapsuleComponent not following the mesh. Even if it’s not, it’s something I’d like to fix.

Oh I thought you only needed the camera to follow the mesh, my bad.

After a bit of testing i got something that seems to work pretty good.

  1. Create a socket at spine_01 in the UE4_Manneqin_Skeleton
  2. Disable CapsuleComponent collision
  3. Mesh - Simulate Physics
  4. Attach Capsule to the Socket
    Blueprint:
    Capture2.PNG
    Result:
    Capture.PNG

fd3520bbfd5a7529a6eb33bacf1d4757.png
e87f5cedd7fb39bc9d023e120c8db859.png

It’s still not working. Whenever I activate ragdoll mode, the capsule disappears altogether.

EDIT: I was wrong actually. It’s still there, but it stays standing upright, and you can move it with the WASD keys as if it were the player…

Change “Keep Relative Offset” to “Keep World Position”.

If you don’t want the player to be able to move, just add a call to “Disable Input”.

Ah, I somehow missed that. Thanks!

Odd issue - after lying on the ground for a minute in ragdoll mode, or after falling down for long enough, the player disappears entirely.