Download

Problem with character hair when imported from Reallusion Character Creator 3 to Unreal Engine 4

Hello, i have created a character with Reallusion Character Creator 3 and then i imported the character to UE4 (i followed one of their tutorials on how to import it and i used the CC Setup plugin) and the hair is on the right place at first but when you press play or when i open the skeletal mesh, the hair disperse and fly off the head and then gather right between my character’s legs (see pictures). I am new to this and i have no idea what is happening here. Not sure if this is an issue with the export from Reallusion Character Creator 3 or if the issue is with Unreal Engine. Can anyone please help me?

I had a problem like this but with the jaw bone… What I found was when importing the skeleton I was using had custom bones… go to skeleton, retarget manager and click on “show advanced”
See if there are custom bones at bottom, what happens is the cc3 skeleton overwrites some of these… Hope this will help.

Thank you for the reply. Yes you were right, there are some custom bones “custom_1” through “custom_5” and they are all empty except the first one, which has “cc_base_jawroot” selected. There are also quite a few cc_base bones in the dropdown menu (for neck, toes, teeth, eyes, tongue etc). What should i do? Should i just delete the customs, or should i assign the right bones in the customs (which i am not sure how to do)?

Do not delete any custom bones, Does your original skeleton have any custom bones that may have been over written ?, It is hard to say what the problem is without knowing how it was imported etc etc… what version of UE4??

I didn’t add any custom bones, if that is what you mean. I just created a basic model with the program and then followed a tutorial that showed how to export the model from character creator and import it to unreal engine. I didn’t do anything to the bones manually, it was all done by the program by default. From what i can tell though, the bones are exactly like the UE third person mannequin, apart from the cc_base_jawroot bone which was assigned to “Custom_1” and there are quite a few other bones from the skeleton tree like eyes, neck, head etc, that are not assigned to anywhere in the retarget manager, at least from what i can tell. I also retargeted the third person character animations to my new model and they worked fine, except from the hair of course(i don’t know if this helps, i just thought to mention it just in case). Sorry i am kinda new to this.

Here are my import settings and i also used the cc_setup plugin. The UE version is 4.26.1

I think you should try this video to import, https://www.youtube.com/watch?v=0xDzfeDfEDI . This uses the ue skeleton, make sure plugin in activated and fallow his instructions, Also with the plugin
all materials are installed so you dont have to import !! Another question… that is stock hair from CC3?? I have not tried with 4.26 too many buggzzz I will install plugin and try to see if it works… Have patience and we will solve this. I will see what I can get done tonight and will check back tomorrow morning…

EDIT: Also using that vid you do not have to retarget animations… Had a character setup with and tried in 4.26 and did not have any problems except for
some morph target weights on cloths but everything was in place … Hope this works…

You are awesome, that fixed the hair so thank you very much, i really appreciate it. The hair are on the character’s head now, as they should so i can sleep better at night now :stuck_out_tongue: . The only slight problem is that the hair physics are not all that great. They are not terrible but for example when the character makes big moves they move around like they are completely weightless, but i guess that is a completely different issue that probably needs some adjusting or something. And there is also another issue (which existed before and is also unrelated to the hair issue, that is now fixed). The animations and everything are working perfectly without even retargeting as you said, but when i use the character with the controlrig for animation sequences, the character is like someone punched her head and shoved it between her shoulders. This only happens when i replace the skeletal mesh of mannequin_female_controlrig with my model for the sequences. If you also have any ideas about those 2 issues, that would be great. If not then thank you anyway, after all you already helped a lot so i am not complaining. Here are the pictures.

P.S. although the issue is solved now but to answer your question, yes it was stock hair from CC3.

Glad it worked for you. there are other vids that show how to fix the physics problems, I will try to find links to these for you but will need some time, I have not tried with controlrig yet but I can try
and will let you know what I find. Again will need some time. The head problem could be because of scaling… Keep trying things and always backup your work. Will talk soon.!!

Edit:
https://www.youtube.com/watch?v=D2sf5P5-w44
Try this for starters!!

Yes thank you that helped. I followed the video about the hair physics and then adjusted the gravity scale and it seems to work fine now. And of course take as much time as you need, the fact that you are helping is more than enough, i wouldn’t expect you to drop everything else to help me, so it’s totally fine :slight_smile:

Glad to help, I have been using CC3 for only a year and there is lots to learn, I recommend watching the CC3 video’s about optimization, even check out Iclone vids because alot of that is used in
CC3 ! My first character I think I spent 2 weeks tweeking things. Big learning curve !!

Thanks again for all your help, i will check out these videos and if by any chance you come across a solution to the controlrig issue, please do let me know (when and if you find the time of course).