Download

Problem with bp_sky_sphere in 4.7

In 4.6.1 i can add bp_sky_sphere and see sun. But in 4.7 when i add sky_sphere there is no sun, only clouds. I can see it in reflections but not in the sky. I really need help with this. I haven’t changed anything in the blueprint.

Seems like a bug or some changes in the material/blueprint -> a temporary fix is to enable “Transculent” in your material + add a constant vector with a value of <1 to the opacity :slight_smile:

Do you think, reinstalling 4.7 would help? I’m kinda new to UE so could you explain more in detail on this temporary fix? I would really apprecieate it.

Nope, reinstalling the engine wont help in this case :wink:

  1. go to the scene outliner - right click onto the skybp - “Find in content browser”
  2. open the material “M_Sky_Panning_Clouds2”
  3. do those modifications (with the constant vector you can change the transparency):

2ce30514e5a08f9b4625c10b873d5cb4d73ce85d.jpeg

c504f857a4be3ea4c876a65f75932a58ee136263.jpeg

I did everything just as you said, and it’s the same as before :confused:

http://imgur.com/AdXzERl,9ExLmZz - this is how this looks in the engine.

Why do you show the cube? -> take a look at the sky, then you should see the sun :slight_smile: Also make sure to use a value under 0.9 for the constant vector.

When you still dont see the sun, post me your material setup + test it in the example map + rebuild the light + set your quality settings to “epic”

Okay i added atmospheric fog and decreased opacity now i have sun thanks for help :slight_smile: Also there is second image in this link, u have to click on it.

Ohhhhh… :o Nice that it’s working now :slight_smile:

Only problem with this is i cant change sun settings in bp_sky_sphere. Sun only shows if i add atmospheric fog into the scene.

This happens also in other example projects, like it’s affecting every project, not only mine.