Download

Problem when importing UV Channel

Hello, I know there are several similar threads about this issue, but I couldnt find a solution.

I have this simple box for using as a floor. Normally in 3dsmax I use UVW Mapping for this kind of meshes. Then I add another Edit Poly modifier and select each face for adjusting the texture.
All of these UV Maps are in channel 1 of the mesh and they are just the Diffuse map for reference in UE4. -pic related-


When I have all the object textured, I add a Unwrap UVW modifier in channel 2 for lightmap.

Now I export the fbx, and import it inside UE4 deselecting textures and materials.
I create a material with the wood texture attached to base color (no Texture Coordinates as I’m not scaling the object and I want it 1:1) and I apply the material to the mesh.
I build the lightning just in case and this is the result :
370be55e3e091de7fae2004ebd1152ff00c70f3a.jpeg

Wood grain is smaller and its not maching the different faces. I could trick it using Text. Coords, but for large projects it would be unviable.

Am I doing something wrong? I’ll appreciate any kind of help.

I haven’t used max in a while but when I did I remember collapsing the stack a lot more than most users. From what I can see you have a lot of unwrap modifiers on it. Try either one at a time and exporting it that way until it breaks to discover which one may be messing you up, or build one uv channel and then collapse the stack and add a new uv modifier to build the next one. That’s not a very good Max user workflow but it may be a work around for this asset.

Thanks for answering. I collapsed them and the issue persisted.
I tried with different textures and I found out something, its better explained on the picture below :

c2563f1009e80f87e5e4f4649e884f2e6e85a823.jpeg

Somehow those textures dont work properly. I tried to resize them to 2048 or lower resolution, even changing to png or jpg.
But when I tried ones with 6000x8000 / 1536x2048 it worked just fine.
I tried almost every export/import options in each program.

What Im missing here?

If you’re still having trouble is there any way you can share the max file?

Sure, here are the files
http://www18.zippyshare.com/v/33469538/file.html
I packed both .max (2014 version, if you need earlier one just ask) and .fbx 2013. Its just the mesh, I didnt include its collision box.
The other big file is the texture I used, 6000x6000 jpg, raw.

I think I see what’s going on here. Your UV’s are stretched on the top face. You need to relax the top face and scale it to match the grain on the end. The reason why one non uniform size texture works and the other doesn’t is because the way the program stretches uvs to match a non square texture. So like I said relax the top face and scale it up to match. If I’m not explaining it very well let me know and I’ll post pictures.

Also you really should lower your texture sizes, 6k is way too big especially for a tilling texture that doesn’t have much detail on it. In general I stay around 1024 unless its a big object or a hero prop, then multiple 2048 maps if necessary.

I’d really appreciate if you could post some pictures. I think I got the point but Im still missing something :rolleyes:

Open up a unwrap modifier for the diffuse texture slot. In this case channel 1 in max.

Select the top face and run a relax on it (you may have to do this to other faces as well).

Make sure you are relaxing by polygon in this case.

The texture will be off but thats ok.

Scale up the UV’s for that face until the texel density matches and the grain is the right size.

Here is what it looks like in engine.

EDIT: Oh, btw I messed with the levels and size of the texture so I could see the grain better.

Thank you a lot BackedUp20. Awesome help, I’ll try it as soon as I can.

Of course. No problem. Hope this helps. :slight_smile: