Problem w/ ROG SWIFT G-SYNC + UE4 Full-Screen Mode

Hey Everyone,

I just tested going full screen on my ASUS ROG SWIFT monitor and it can’t do it. It works if I run my game in-editor and press F11 but that’s still a form of windowed mode I believe. When I go full screen, it is scaled down considerably with a lot of black space surrounding it. Tested full-screen on my 1080p monitor and no issues there so there may be a confliction with G-Sync monitors/drivers. Really was looking forward to running the new Apollo 11 demo on this monitor :frowning:

Not to mention I hope I didn’t make a bad investment in this monitor. I’m sure someone has one of these monitors and knows of this issue so fingers crossed.

Thanks!

Just updated to the latest driver…

https://3gct8a.by3302.livefilestore.com/y2pp4TyDDe4VdB1NNxwsIuZZOkAY8BEOx_ltf7yDYMqHg4wjuWbeN4ojf1KxOZsXmHqA5hGiBLWIq5ll5Tf7VuVPqxVX5ExoqA5PAQlTuWZAO0/WP_20141111_16_22_37_Pro.jpg

and it’s better, probably about 50% less scaled down but the resolution is not matching up. My resolution is 2560x1440 and my guess is what I was looking at was 1440p rendered with a 1080p render target. Or at least that’s how it appears to me.

As a note, every other game I’ve tested with this monitor works but this only happens in UE4. (However, I have never tested my UE4 game at 2560x1440 yet so it’s possible that would work correctly)

Thanks!

UPDATE: Just ran the demo again and the G-Sync light went Red so it’s definitely running full-screen and I noticed upon exiting the app, there is a split second where it appears to go from 1080p to 1440p resolution. So it seems the demo is set to 1080p but this is confusing. If the demo were 1080p and there is an issue where it’s stuck at 1440, but that doesn’t explain why Windows appears to do a quick resolution change following exit of the tech demo because if it were at 1080, it should be scaled up so I’m at a loss on this one.

On another note, man is VXGI sweet but man does it kill performance even on a 980. One thing I’m curious is if NVidia’s branch of UE4 had the parallel rendering efforts implemented. I’m hoping not :wink: so there is room for improvement.

Hello MC Stryker,

You seem to be troubleshooting well on your own, but I would be glad to help you. Now I am a bit lost however, as to what your issue is? :slight_smile:

If you could clarify your current state and your current question we can move from there?

Thanks,

Andrew Hurley

Hey Andrew, lol, yea I’m trying. It looks like my image was attached wrong and I can’t see it so I’m guessing you didn’t either. Basically in fullscreen mode on this monitor in UE4, the final render target is not being scaled up to the native resolution of the monitor. You’ll see in the image, that it isn’t fully taking up the display and I did notice going from the previous driver that it took up more of the display but still didn’t get there.

This what the issue looks like…

Thanks Andrew!

EDIT: DotCam let me know it didn’t work so let’s try this one… fingers crossed

https://onedrive.live.com/redir?resid=2D24BE74E7380A5D!10854&authkey=!AFBszN0Shl6MpCY&v=3&ithint=photo%2Cjpg

Maybe this…
https://onedrive.live.com/redir?resid=2D24BE74E7380A5D!10854&authkey=!AFBszN0Shl6MpCY&v=3&ithint=photo%2Cjpg

Hello again MC Stryker,

Have you tried going into your display settings of your monitor and changing the resolution? This seems to be a global problem and not just within the editor itself. Perhaps your scale or ratio is not correct, or the native resolution is not right?

Let me know. Also within the editor there are some console commands to force fullscreen mode. Press the command line prompt (~) and type in "r.Setres DesiredResolutionxDesiredResolutionf

The “f” at the end means fullscreen.

Hope this helps,

Andrew Hurley

Hey Andrew,

Thanks for checking back. Yes I have checked the resolution and this is unfortunately only present on just UE4. The problem was noticed in the Apollo 11 demo so I unfortunately cannot pull up the console in that demo. I could definitely pull up my own project but not sure if that’s going to help us much.

I can go fullscreen in other games and everything works fine but I only notice this on this particular monitor. It may be because I run everything at the native 2560x1440 but I’m pretty sure I’ve tested other fullscreen resolutions on this monitor but it is something I could look into later.

But maybe Epic needs to get you one of these monitors so you can test cough :wink: It’s a pretty rad monitor.

I would have to check later but my guess is if I ran a game at the non-native resolution, not just a UE4 project, then it would show the same symptoms. I doubt there is something specific that Epic would need to implement for G-Sync anyway since it’s all handled by the module and gfx card. It also could have something to do with the monitor being set at 144Hz but if I get a chance tonight, I will test these out for you to try and get some more info.

Hey MC Stryker,

It sounds like you have a few solutions to your own issue. And yes, it does sound like a pretty sweet display, but after testing your resolutions and they do not work we will continue to investigate!

Thanks,

Andrew Hurley

Hey Andrew. I’m actually dealing with some issues right now with ASUS and just got a defective replacement for a defective unit, go figure :stuck_out_tongue: But as soon as I do get a working model, I’ll revisit this with you and test what I mentioned above to hone down if this is specifically related to UE4. Take care Andrew.

That’s a bummer :frowning: I hope it gets worked out soon. Sounds good though, I will be in touch.

Thanks :slight_smile:

Andrew Hurley

Me too Andrew. Thanks for the support buddy!

Hi all

I know this is a very old post but just came across this as I’m having the same issue with the same monitor and this is the only post I can find with this issue. I haven’t actually come across this with UE4 itself but with a few games that use UE4. Basically if I can run a game in windowed mode it works fine but if i go to full screen the game become unplayable an usually i cannot get it back to window mode. This doesn’t for all UE4 games Paragon works fine but Fragmented and Hatred have both had issues (see screenshot). I’ve tried changing screen resolution and turning off g-sync but it hasn’t worked. I’ve also checked that I have the latest drivers, etc Any ideas?