Download

Problem Retargeting Animations

Hi, I am trying to retarget an animation that comes from unity, and I want to use it with the standard character of unreal engine but I cannot do this, I am getting an error

I’m new in Unreal Engine, I come from Unity (I am using Unreal Engine 4.14)

This is my problem:

c488f5e46eba875bdba483b2d4b6d65c21242ee2.png

The source is empty instead of show my mesh

So When I hit Retarget I get this error:

77db32d1de64a593dadf818904462fba08945ded.jpeg

This is my mesh:

mesh.jpg

This is my skeleton:

skeleton.jpg

This is my animation:

animation.png

This is my retarget manager:

retarget manager.png

This is the skeleton of the target

target skeleton.jpg

What happens if you hit the “View Pose” button followed by “SavePose” button in the retarget manager of your source mesh? There is even some star at the icon of your source skeleton mesh. Did you try after selecting your source skeleton mesh and hitting the save button? I remember I did not see a preview mesh if I tried to regartet existing anims to a new imported mesh (that was not saved yet) and that did not show in the preview at the right side afterwards. However in that case retargetting still worked. Probably it must be saved if it’s the source and not the target mesh.