Problem open level from Main Menu

I´ve made 2 levels, one for my Main Menu and one for my game map, I´ve made those levels just by right clicking in the content browser on then “Level”. The game works just fine when i play it in the level editor viewport, but when i press the launch button it fails launching if I choose the computer, and if I choose my android phone it launch successful but the when i play the game it is just black when I press “Play Game”

Fail Error:


PackagingResults:Error: Error Launch failed! Unknown Error

MainMenu Level Blueprint:

Main Menu HUD Blueprint:

I have tried to make new projects with just the things that does not work but still same problem );

Have I missed something or are my UE4 broken???
Please HELP!!!


What’s happening most likely is that your second map is not being cooked. When you Launch onto a device, it will not always cook all of your maps, it will typically only cook the default.

Instead of launching, try packaging the game out and seeing if you can get the map to work that way. If your packaging process fails, please provide the full output log from your project’s Saved->Logs folder.

Thank you!

Thanks a lot man, it worked when I packaged the game instead of launching.
I really appreciate your help :slight_smile:

Glad you got it working.

Have a great day!