Download

Problem on Behavior tree: Observer abort both option

Hi everyone, I’m following the written guide on the Unreal documentation to build an AI. I’ve already builted it in a new top down project, to test it out, and it worked perfectly.
Now I’m trying to build it in my own project, but I got stuck on the 14th step (https://docs.unrealengine.com/latest/INT/Engine/AI/BehaviorTrees/QuickStart/14/index.html): I’ve added the two decorators on the selector, and now I should set the “observer abort” as “both”, in the Blackboard decorator, but I only have the two options: “none” and “self”. Why am I missing the other two options?

Immagine.png

I hate the observer aborts stuff and only ever thought that I understood it.

Is it because the Blackboard is Selected?

Uhm… What do you mean? The observer aborts that I’m trying to set is the Blackboard decorator one.
On the top down template it worked fine, what could be the reason why on my project this happens? Maybe something missing? Mine was a Blank project, Not a template

Up, didn’t find a solution yet

did u try deleting then adding the decorator? I had issue few days ago when whenever I click on a decorator the engine crashed and I fixed it by deleting and adding the same decorator again

Yep, I tried! Anyway, I rebuilt the entire IA (following again the tutorial, step by step) and that issue didn’t showed up, luckily.
BUT I met another problem: this time it is an error, in the “Follower_AI_CON” Blueprint…

12773367_10206955833586718_1870346841_o.jpg

really can’t understand, what does it mean? My blueprint is the same as the tutorial one. This isn’t the first time I meet that error, but I remember that the first one I just copy-and-pasted the entire blueprint from the project that I use for practice, to my game project… what’s wrong with this AI?

Ok, here is my assumption, if you follow your blueprint and it is true then take it as a solution otherwise ignore :smiley:
This issue does not cause your game to fail to compile instead it appears as you press stop after play or simulate… True?
you are calling for a valid value before setting it… that’s why set value as vector shows error. In case you did not figure a solution show me the blueprint and I show you what and where.

Yeah, right! I start play, and the enemy pawn I placed just does not move. When I hit Esc to stop the game, a pop up notifies me about the error.
Here’s the blueprint, seems that the error is caused by the “get controlled pawn” node.

ce927d0353233e76bba824b0c68b5602e0614224.jpeg

I don’t know how to solve that, the blueprint is the same as the tutorial’s one so I can’t even figure out where to modify it.
The first time I tried to build this AI was on a random Top Down template, and it worked on the first try. Then I re-built it on a copy of our project, and I met two problems: this one (exactly the same error) and the observer abort I explained above. I solved the first one just copy-and-pasting the entire “follower Ai CON” bp from my Top Down template, and it worked, but instead I didn’t succeded on solving the observer abort problem. Anyway, I builted a third time the AI on our real project, with a friend of mine who’s working with me. The observer abort’s problem did not showed up, everything was fine, exept for this error; this time the “copy and paste” strategy didn’t work.

Up please
We haven’t solved it yet.

Thank you guys!

I’m having this same issue. On another decorator node in this very same graph I am able to “abort both”, but I copy and pasted that node and only “none” or “self” are available! I deleted the other decorator and it still doesn’t let me select “both” on this new decorator. Any solution?

f00d7b876410ae89604a3788e9a1de2b4448e0f8.png

I think only the decorators under a Selector are able (or sane) to use the Abort Lower Priority/Abort Both.
I get this by experimenting, but not sure the logic behind it.

Found the solution. “Both” and “Lower peiority” will be available if you change sequince composite node to selector after the root node.

‘self’ and ‘none’ under seq, ‘none’ ‘self’ ‘lowp’ and ‘both’ under select.

You need to use a selector instead a sequence