Download

[Problem] No working Collision Meshes in ARK Dev Kit

Hi friends :slight_smile:

I am in big trouble: I can’t apply collision meshes to my assets/meshes.

I am working with Blender 2.74.

In Unreal Engine 4 it is working well! But in ARK Dev Kit the same meshes have no collision. Nevermind, what method i use. (Aply simple box, apply convex hull, or apply auto collision in ARK Dev Kit).

My WIP Mod “Sealive” is thwarted by this issue.

Best regards
Vertebrat

Why not just use their existing presets for something similar? (maybe use the rock’s collision?) Or have it generate a new collision when importing the mesh? You should get an option when importing a new mesh to have it generate a collision for it. If you do that, then it should be accurate enough :slight_smile:

Edit: you are using .fbx or .obj when importing?

As you can read, i tried 3 different methods, followed the tutorial from fighter5347:

  • Making in Blender a simple Box UCX_mesh and export as .fbx file. And of course import it as such. I tried different settings as mentioned above while importing: Enable/disable “Auto Collision” & enable/disable “One Convex Hull Per UCX”. Nothing have an impact.

  • Making in Blender a Convex Hull UCX_mesh and export as .fbx file. and the same as the line above.

  • Doing nothing with collision in Blender, export as .fbx file and set “Auto-Collision” to “true”. At the Static Mesh editor (I still try Static Mesh only, that’s easier for me as a newby in any Game Engine) i can see a Auto Collision Mesh, but it is not working. So then, I tried to set the Auto Collision setting to “Collision Complex as Simple” and/or “Collision Simple as Complex”, but nothing works.

BUT Doing the last step at Unreal Engine 4, it works like a charme. But not at the ARK Dev Kit. Why? There seems to work nothing for me? Or is there a mistake i ingored the whole time?

I never export/Import as .obj in this case. Should i try? :slight_smile:

EDIT: With .obj is not possible to enable any collision mesh. In any way.

Change the Collision Profile of your StaticMeshActor to “BlockAll”. Unlike Stock UE4, we made StaticMeshActors have no collision type by default :wink:

Woah … thank you very much!

I’ve really doubted gradually to my brain. :cool:

Now this thread can be closed. StudioWildcard gave the solution :slight_smile: Thank you again.

CLOSED.