Problem: Mouse Cursor limits camera rotation (screen-edge blocks cursor even when turned off)

Hello. I would like to get some attention on this problem: When you have the mouse cursor enabled, it limits the camera rotation via mouse. The problem is that the camera rotation stops as soon as the mouse hits the end of the screen.

Disabling the cursor when you “start” your camera rotation doesn’t help, as the engine somehow still acts like the cursor is enabled. The problem occurs both when you enable the cursor in the controller, as well as manually in a blueprint.

It would be really great if this could be fixed, because there doesn’t seem to be any workaround for it so far.


“Set input mode game only” node would solve your problem. Event tick - set input mode game only.

1 Like

Besides that using an event tick is a terrible idea (in this case), your suggestion does not work, I tried it. But thanks for the suggestion anyway.

I solved it with a different method, which is more reliable.

It could be real helpful to others to hear about this “different method”.


I love the “different method” solution! Thanks for sharing so I could solve the problem as well.